summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2016-07-06 01:14:51 +0200
committerFabian Maurer2016-07-06 01:14:51 +0200
commit0283823cce7734629183e7f977a3933d545c9d6a (patch)
treec102eedefe30e560d1e089f2273444782ff724cd
parent1b5f7b30b5b0f7ad0ba6ed93505c81d9f0948cd0 (diff)
downloadaur-0283823cce7734629183e7f977a3933d545c9d6a.tar.gz
Linked the jre-directory, so the scripts can find it without being patched.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--mkfs.patch6
3 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd448195e882..4cae0b4032c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sdfs
pkgdesc = Deduplication file system from Opendedup
pkgver = 3.1.7
- pkgrel = 1
+ pkgrel = 2
url = http://opendedup.org
arch = x86_64
license = GPL2
@@ -10,10 +10,8 @@ pkgbase = sdfs
depends = fuse
source = https://github.com/opendedup/sdfs/archive/3.1.7.zip
source = mount.patch
- source = mkfs.patch
md5sums = cdc1af3868c8a2660e16796fcee6f636
md5sums = SKIP
- md5sums = SKIP
pkgname = sdfs
diff --git a/PKGBUILD b/PKGBUILD
index f5170dd0bb57..a72cd36700c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=sdfs
pkgver=3.1.7
-pkgrel=1
+pkgrel=2
pkgdesc="Deduplication file system from Opendedup"
arch=('x86_64')
url="http://opendedup.org"
license=('GPL2')
depends=('libxml2' 'java-environment' 'fuse')
source=('https://github.com/opendedup/sdfs/archive/3.1.7.zip'
- 'mount.patch'
- 'mkfs.patch')
+ 'mount.patch')
md5sums=('cdc1af3868c8a2660e16796fcee6f636'
- 'SKIP'
- 'SKIP')
+ 'SKIP')
prepare() {
cd ${srcdir}/$pkgname-$pkgver/install-packages/deb
+
patch usr/share/sdfs/mount.sdfs < ${srcdir}/mount.patch
- patch usr/share/sdfs/mkfs.sdfs < ${srcdir}/mkfs.patch
+
+ ln -s /usr/lib/jvm/default-runtime usr/share/sdfs/bin/jre
}
package() {
diff --git a/mkfs.patch b/mkfs.patch
deleted file mode 100644
index fa4054d026d9..000000000000
--- a/mkfs.patch
+++ /dev/null
@@ -1,6 +0,0 @@
---- mkfs.sdfs 2016-07-03 00:48:24.582190077 +0200
-+++ mod-mkfs.sdfs 2016-06-06 21:54:29.000000000 +0200
-@@ -1,2 +1,2 @@
--/usr/share/sdfs/bin/jre/bin/java -Dfile.encoding=UTF-8 -classpath /usr/share/sdfs/lib/sdfs.jar:/usr/share/sdfs/lib/* org.opendedup.sdfs.VolumeConfigWriter "$@"
-+java -Dfile.encoding=UTF-8 -classpath /usr/share/sdfs/lib/sdfs.jar:/usr/share/sdfs/lib/* org.opendedup.sdfs.VolumeConfigWriter "$@"
-