summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2022-04-27 09:07:22 +0200
committerNicolas Iooss2022-04-27 09:07:22 +0200
commit02cb906621b8a4cb3d5469449e0334f254642a91 (patch)
treef12265dc80c6b167ff60a8c0a4f30115dd231db8
parent4765619d1f2b84eefafcc05f25d64a96affe97e8 (diff)
downloadaur-02cb906621b8a4cb3d5469449e0334f254642a91.tar.gz
coreutils-selinux 9.1-1 update
-rw-r--r--.SRCINFO16
-rw-r--r--01-fix-fs72253.patch92
-rw-r--r--PKGBUILD12
3 files changed, 12 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37650143d6bc..b72200db071f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coreutils-selinux
pkgdesc = The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support
- pkgver = 9.0
- pkgrel = 2
+ pkgver = 9.1
+ pkgrel = 1
url = https://www.gnu.org/software/coreutils/
arch = x86_64
arch = aarch64
@@ -14,16 +14,14 @@ pkgbase = coreutils-selinux
depends = libcap
depends = openssl
depends = libselinux
- provides = coreutils=9.0-2
- provides = selinux-coreutils=9.0-2
+ provides = coreutils=9.1-1
+ provides = selinux-coreutils=9.1-1
conflicts = coreutils
conflicts = selinux-coreutils
- source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.0.tar.xz
- source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.0.tar.xz.sig
- source = 01-fix-fs72253.patch
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.1.tar.xz
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.1.tar.xz.sig
validpgpkeys = 6C37DC12121A5006BC1DB804DF6FD971306037D9
- sha256sums = ce30acdf4a41bc5bb30dd955e9eaa75fa216b4e3deb08889ed32433c7b3b97ce
+ sha256sums = 61a1f410d78ba7e7f37a5a4f50e6d1320aca33375484a3255eddf17a38580423
sha256sums = SKIP
- sha256sums = aefec296212c10f8ddae10225216847f537e573d80b678161f453b34fd183bf5
pkgname = coreutils-selinux
diff --git a/01-fix-fs72253.patch b/01-fix-fs72253.patch
deleted file mode 100644
index ad2b068875bc..000000000000
--- a/01-fix-fs72253.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From e8b56ebd536e82b15542a00c888109471936bfda Mon Sep 17 00:00:00 2001
-From: =?utf8?q?P=C3=A1draig=20Brady?= <P@draigBrady.com>
-Date: Fri, 24 Sep 2021 20:57:41 +0100
-Subject: [PATCH] chmod: fix exit status when ignoring symlinks
-
-* src/chmod.c: Reorder enum so CH_NOT_APPLIED
-can be treated as a non error.
-* tests/chmod/ignore-symlink.sh: A new test.
-* tests/local.mk: Reference the new test.
-Fixes https://bugs.gnu.org/50784
----
- src/chmod.c | 4 ++--
- tests/chmod/ignore-symlink.sh | 31 +++++++++++++++++++++++++++++++
- tests/local.mk | 1 +
- 4 files changed, 40 insertions(+), 2 deletions(-)
- create mode 100755 tests/chmod/ignore-symlink.sh
-
-diff --git a/src/chmod.c b/src/chmod.c
-index 37b04f5..57ac47f 100644
---- a/src/chmod.c
-+++ b/src/chmod.c
-@@ -44,8 +44,8 @@ struct change_status
- enum
- {
- CH_NO_STAT,
-- CH_NOT_APPLIED,
- CH_FAILED,
-+ CH_NOT_APPLIED,
- CH_NO_CHANGE_REQUESTED,
- CH_SUCCEEDED
- }
-@@ -322,7 +322,7 @@ process_file (FTS *fts, FTSENT *ent)
- if ( ! recurse)
- fts_set (fts, ent, FTS_SKIP);
-
-- return CH_NO_CHANGE_REQUESTED <= ch.status;
-+ return CH_NOT_APPLIED <= ch.status;
- }
-
- /* Recursively change the modes of the specified FILES (the last entry
-diff --git a/tests/chmod/ignore-symlink.sh b/tests/chmod/ignore-symlink.sh
-new file mode 100755
-index 0000000..5ce3de8
---- /dev/null
-+++ b/tests/chmod/ignore-symlink.sh
-@@ -0,0 +1,31 @@
-+#!/bin/sh
-+# Test for proper exit code of chmod on a processed symlink.
-+
-+# Copyright (C) 2021 Free Software Foundation, Inc.
-+
-+# This program is free software: you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation, either version 3 of the License, or
-+# (at your option) any later version.
-+
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+# GNU General Public License for more details.
-+
-+# You should have received a copy of the GNU General Public License
-+# along with this program. If not, see <https://www.gnu.org/licenses/>.
-+
-+. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+print_ver_ chmod
-+
-+mkdir dir || framework_failure_
-+touch dir/f || framework_failure_
-+ln -s f dir/l || framework_failure_
-+
-+# This operation ignores symlinks but should succeed.
-+chmod u+w -R dir 2> out || fail=1
-+
-+compare /dev/null out || fail=1
-+
-+Exit $fail
-diff --git a/tests/local.mk b/tests/local.mk
-index 228d0e3..b5b893f 100644
---- a/tests/local.mk
-+++ b/tests/local.mk
-@@ -456,6 +456,7 @@ all_tests = \
- tests/chmod/c-option.sh \
- tests/chmod/equal-x.sh \
- tests/chmod/equals.sh \
-+ tests/chmod/ignore-symlink.sh \
- tests/chmod/inaccessible.sh \
- tests/chmod/octal.sh \
- tests/chmod/setgid.sh \
---
-1.9.1
-
diff --git a/PKGBUILD b/PKGBUILD
index bb5d3240167c..e87e3968dda9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=coreutils-selinux
-pkgver=9.0
-pkgrel=2
+pkgver=9.1
+pkgrel=1
pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support'
arch=('x86_64' 'aarch64')
license=('GPL3')
@@ -21,12 +21,10 @@ depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl' 'libselinux')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-source=("https://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig}
- '01-fix-fs72253.patch')
+source=("https://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig})
validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
-sha256sums=('ce30acdf4a41bc5bb30dd955e9eaa75fa216b4e3deb08889ed32433c7b3b97ce'
- 'SKIP'
- 'aefec296212c10f8ddae10225216847f537e573d80b678161f453b34fd183bf5')
+sha256sums=('61a1f410d78ba7e7f37a5a4f50e6d1320aca33375484a3255eddf17a38580423'
+ 'SKIP')
prepare() {
cd ${pkgname/-selinux}-$pkgver