summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2015-10-03 01:55:36 -0400
committerYaohan Chen2015-10-03 02:01:54 -0400
commit02cd3be9bc51152439d323b0f76a35f994f33133 (patch)
treed0d1fff3c8c4c5ce53b50bf7774e760f17bb870e
downloadaur-02cd3be9bc51152439d323b0f76a35f994f33133.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rwxr-xr-xargentum-age-git.sh2
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9111803f34c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = argentum-age-git
+ pkgdesc = A digital collectible card game with tactical elements.
+ pkgver = 0.0.1853.g5a4ccf1
+ pkgrel = 1
+ url = http://argentum-age.com/
+ arch = any
+ license = custom
+ makedepends = git
+ depends = anura-git
+ provides = argentum-age
+ provides = anura-citadel-git
+ conflicts = argentum-age
+ conflicts = anura-citadel-git
+ source = git+https://github.com/davewx7/citadel.git
+ source = argentum-age-git.sh
+ md5sums = SKIP
+ md5sums = ad03a90e4ee6019c28e91fa89d5c689c
+
+pkgname = argentum-age-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71de472d43fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=argentum-age-git
+pkgver=0.0.1853.g5a4ccf1
+pkgrel=1
+pkgdesc="A digital collectible card game with tactical elements."
+arch=(any)
+url='http://argentum-age.com/'
+license=('custom')
+depends=(anura-git)
+provides=(argentum-age anura-citadel-git)
+conflicts=(argentum-age anura-citadel-git)
+makedepends=('git')
+source=(git+https://github.com/davewx7/citadel.git
+ argentum-age-git.sh)
+md5sums=('SKIP'
+ 'ad03a90e4ee6019c28e91fa89d5c689c')
+
+_gitname=citadel
+
+pkgver() {
+ cd $_gitname
+ if _tag=$(git describe 2>/dev/null)
+ then
+ # Use the tag of the last commit
+ echo $_tag | sed 's|-|.|g'
+ else
+ # The project currently has no tags yet
+ echo 0.0.$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+ fi
+}
+
+package() {
+ cd "$_gitname"
+
+ _installdir="$pkgdir/usr/share/anura-git/modules/argentum-age"
+ install -DT -m644 module.cfg "$_installdir/module.cfg"
+ install -DT -m644 master-config.cfg "$_installdir/master-config.cfg"
+ mv data images sounds music "$_installdir"
+ install -D -m755 "$srcdir/argentum-age-git.sh" "$pkgdir/usr/bin/argentum-age-git"
+ install -DT -m644 LICENSE "$pkgdir/usr/share/licenses/argentum-age-git/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/argentum-age-git.sh b/argentum-age-git.sh
new file mode 100755
index 000000000000..e101955814f7
--- /dev/null
+++ b/argentum-age-git.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+anura-git --module=argentum-age --tbs-server --config-path=~/.argentum-age-git $*