summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-05-11 17:28:44 +0800
committertaotieren2021-05-11 17:28:44 +0800
commit02d2d67794afee5f076a76e9c66b54f1e300cfaa (patch)
tree4e34531907490e295338fd7aa3b769a9499d476a
parentac6dc352e03f199bf7bf429258ce49692a8448e6 (diff)
downloadaur-02d2d67794afee5f076a76e9c66b54f1e300cfaa.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ef49d7aad46..3dd04ead158a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = nucleistudioide
pkgdesc = Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。
pkgver = 202102
- pkgrel = 6
+ pkgrel = 7
url = https://www.nucleisys.com/download.php
arch = x86_64
license = unknow
+ depends = java-runtime
depends = jlink-software-and-documentation
+ optdepends = nuclei-gcc
+ optdepends = nuclei-openocd
options = !strip
source = https://www.nucleisys.com/upload/files/nucleistudio/NucleiStudio_IDE_202102-lin64.tgz
sha256sums = a005671317725f33e177d2ba9272cd77e0c04ef3d28c7cf8de4565c3f83b651e
diff --git a/PKGBUILD b/PKGBUILD
index 39fa8ac7ccb6..04851367a0fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=nucleistudioide
pkgver=202102
-pkgrel=6
+pkgrel=7
pkgdesc="Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。"
arch=("x86_64")
makedepends=()
-depends=('jlink-software-and-documentation')
-optdepends=()
+depends=('java-runtime' 'jlink-software-and-documentation')
+optdepends=('nuclei-gcc' 'nuclei-openocd')
conflicts=()
url="https://www.nucleisys.com/download.php"
license=('unknow')
@@ -22,6 +22,8 @@ package() {
msg2 'Installing Nuclei Studio IDE'
install -d -m755 "${pkgdir}/opt/nuclei"
tar zxf "NucleiStudio_IDE_${pkgver}-lin64.tgz"
+ rm -rf "NucleiStudio_IDE_${pkgver}/NucleiStudio/jre"
+
mv "${srcdir}/NucleiStudio_IDE_${pkgver}/NucleiStudio" "${pkgdir}/opt/nuclei"
msg2 'Instalation of binary file'
@@ -55,8 +57,8 @@ SUBSYSTEM!="usb|tty|hidraw", GOTO="nuclei_rules_end"
# Please keep this list sorted by VID:PID
# nuclei
-SUBSYSTEM=="usb", ATTR{idVendor}=="0403",ATTR{idProduct}=="6010", MODE="666", GROUP="plugdev"
-SUBSYSTEM=="tty", ATTRS{idVendor}=="0403",ATTRS{idProduct}=="6010", MODE="666", GROUP="plugdev"
+SUBSYSTEM=="usb", ATTR{idVendor}=="0403", ATTR{idProduct}=="6010", MODE="666", GROUP="plugdev"
+SUBSYSTEM=="tty", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6010", MODE="666", GROUP="plugdev"
LABEL="nuclei_rules_end"
EOF