summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-06-19 23:55:51 -0400
committerDarvin Delgado2023-06-19 23:55:51 -0400
commit02e5eb34ba71abd3a7e9194522f0d5bcea63d662 (patch)
treeedb9a085230fcc9328e7726e79828e60ec87b3b8
parentd1ec80dbf6cf0c45951458d8d2c3b510cb764817 (diff)
downloadaur-02e5eb34ba71abd3a7e9194522f0d5bcea63d662.tar.gz
add mangoapp
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2de62d83acbb..ad397988fefe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,27 @@
pkgbase = lib32-mangohud-git
- pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32 bit library).
- pkgver = 0.6.9.1.r68.g0ae2e42
+ pkgdesc = 32-bit libraries for MangoHud and MangoApp
+ pkgver = 0.6.9.1.r79.g30748bd
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
makedepends = git
+ makedepends = glfw-x11
makedepends = glslang
- makedepends = lib32-libx11
+ makedepends = lib32-cmocka
+ makedepends = lib32-libglvnd
makedepends = libxnvctrl
makedepends = meson
makedepends = nlohmann-json
makedepends = python-mako
- makedepends = vulkan-headers
depends = lib32-dbus
+ depends = lib32-gcc-libs
+ depends = lib32-libx11
depends = lib32-vulkan-icd-loader
provides = lib32-mangohud
+ provides = lib32-mangoapp
conflicts = lib32-mangohud
+ conflicts = lib32-mangoapp
source = lib32-mangohud-git::git+https://github.com/flightlessmango/MangoHud
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 421fc16d7623..beb12ed237d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=lib32-mangohud-git
-pkgver=0.6.9.1.r68.g0ae2e42
+pkgver=0.6.9.1.r79.g30748bd
pkgrel=1
-pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32 bit library)."
+pkgdesc="32-bit libraries for MangoHud and MangoApp"
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'glslang' 'lib32-libx11' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
-depends=('lib32-dbus' 'lib32-vulkan-icd-loader')
-provides=('lib32-mangohud')
-conflicts=('lib32-mangohud')
+makedepends=('git' 'glfw-x11' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
+depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-vulkan-icd-loader')
+provides=('lib32-mangohud' 'lib32-mangoapp')
+conflicts=('lib32-mangohud' 'lib32-mangoapp')
source=("$pkgname::git+$url")
sha512sums=('SKIP')
@@ -22,8 +22,8 @@ pkgver() {
build() {
local meson_options=(
--wrap-mode=nofallback
+ -Dmangoapp_layer=true
-Dinclude_doc=false
- -Dtests=disabled
$pkgname
)
@@ -34,13 +34,12 @@ build() {
arch-meson "${meson_options[@]}" build --libdir lib32
- ninja -C build
+ meson compile -C build
}
package() {
- meson install --destdir="$pkgdir" -C build --tags runtime
+ meson install -C build --tags runtime,mangoapp --destdir "$pkgdir"
- install -Dm664 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- rm -rf "$pkgdir/usr/share/vulkan"
+ install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/usr/bin"
}