summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2021-07-18 22:10:30 +0100
committerStephanie Wilde-Hobbs2021-07-18 22:10:30 +0100
commit0304c05f0792ead6eb41aa8a75655a15278b091c (patch)
tree78b975e9ad4ba7450d4f817c040d5b32f2e076cb
parent5b528fe96461609426270aebdbbf217b70b29208 (diff)
downloadaur-0304c05f0792ead6eb41aa8a75655a15278b091c.tar.gz
Sync PKGBUILD with community/netdata
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
-rw-r--r--netdata.tmpfiles3
4 files changed, 32 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f14572b7a6f..fe210736f633 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,52 @@
pkgbase = netdata-git
pkgdesc = Real-time performance monitoring, in the greatest possible detail, over the web
- pkgver = v1.29.3.r187.gbbcfd952f
+ pkgver = v1.31.0.r125.gf5c9d6721
pkgrel = 1
url = https://github.com/netdata/netdata/wiki
install = netdata.install
arch = x86_64
license = GPL
- makedepends = git
+ makedepends = cups
depends = libmnl
depends = libnetfilter_acct
depends = zlib
- depends = lz4
depends = judy
depends = libuv
- depends = openssl
depends = json-c
+ depends = libcap
+ depends = lz4
+ depends = openssl
+ depends = which
+ depends = snappy
+ depends = protobuf
+ depends = libwebsockets
+ depends = mongo-c-driver
optdepends = nodejs: for monitoring named and SNMP devices
optdepends = lm_sensors: for monitoring hardware sensors
optdepends = iproute2: for monitoring Linux QoS
optdepends = python: for most of the external plugins
optdepends = python-psycopg2: for monitoring PostgreSQL databases
+ optdepends = python-mysqlclient: for monitoring MySQL/MariaDB databases
optdepends = python-requests: for monitoring elasticsearch
optdepends = hddtemp: for monitoring hhd temperature
+ optdepends = fping: for for fping module
optdepends = apcupsd: for monitoring APC UPS
+ optdepends = cups: for CUPS plugin
optdepends = iw: for monitoring Linux as access point
provides = netdata
conflicts = netdata
+ backup = etc/netdata/netdata.conf
source = netdata::git+https://github.com/netdata/netdata
source = submodule-mqtt_websockets::git+https://github.com/underhood/mqtt_websockets.git
source = submodule-MQTT-C::git+https://github.com/underhood/MQTT-C.git
source = submodule-c-rbuf::git+https://github.com/underhood/c-rbuf.git
- source = netdata.tmpfiles
+ source = submodule-aclk-schemas::git+https://github.com/netdata/aclk-schemas.git
source = netdata.sysusers
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 3f934ddd1f5248f9e11c29050c023d60b76e4098ec9c8d413bb362d43e9242f767fd58310d966076e8400779af8bda2459afcc314b267fcb9f1c84173e14e313
+ sha512sums = SKIP
sha512sums = a910809a823ba58ca7bdaa72e8d68427b48f452c1fbb2343fa182ecb0a091a7640e73af24b8ba2fdd90e00aed8ef53b7fccd25cb8f04ca9b9fa6c8e52223ca66
pkgname = netdata-git
-
diff --git a/.gitignore b/.gitignore
index e9e7a88fc20e..8b7f6095915a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
/submodule-mqtt_websockets/
/submodule-MQTT-C/
/submodule-c-rbuf/
+/submodule-aclk-schemas/
diff --git a/PKGBUILD b/PKGBUILD
index 27d5e457843d..5ce03b5a0996 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,39 @@
pkgname=netdata-git
_gitname=netdata
-pkgver=v1.29.3.r187.gbbcfd952f
+pkgver=v1.31.0.r125.gf5c9d6721
pkgrel=1
pkgdesc="Real-time performance monitoring, in the greatest possible detail, over the web"
url="https://github.com/netdata/netdata/wiki"
arch=('x86_64')
license=('GPL')
-depends=('libmnl' 'libnetfilter_acct' 'zlib' 'lz4' 'judy' 'libuv' 'openssl' 'json-c')
-makedepends=('git')
+backup=('etc/netdata/netdata.conf')
+depends=('libmnl' 'libnetfilter_acct' 'zlib' 'judy' 'libuv' 'json-c' 'libcap' 'lz4' 'openssl' 'which' 'snappy' 'protobuf'
+ 'libwebsockets' 'mongo-c-driver')
+makedepends=('cups')
optdepends=('nodejs: for monitoring named and SNMP devices'
'lm_sensors: for monitoring hardware sensors'
'iproute2: for monitoring Linux QoS'
'python: for most of the external plugins'
'python-psycopg2: for monitoring PostgreSQL databases'
+ 'python-mysqlclient: for monitoring MySQL/MariaDB databases'
'python-requests: for monitoring elasticsearch'
'hddtemp: for monitoring hhd temperature'
+ 'fping: for for fping module'
'apcupsd: for monitoring APC UPS'
+ 'cups: for CUPS plugin'
'iw: for monitoring Linux as access point')
source=("$_gitname::git+https://github.com/netdata/netdata"
"submodule-mqtt_websockets::git+https://github.com/underhood/mqtt_websockets.git"
"submodule-MQTT-C::git+https://github.com/underhood/MQTT-C.git"
"submodule-c-rbuf::git+https://github.com/underhood/c-rbuf.git"
- "${_gitname}.tmpfiles"
+ "submodule-aclk-schemas::git+https://github.com/netdata/aclk-schemas.git"
"${_gitname}.sysusers")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '3f934ddd1f5248f9e11c29050c023d60b76e4098ec9c8d413bb362d43e9242f767fd58310d966076e8400779af8bda2459afcc314b267fcb9f1c84173e14e313'
+ 'SKIP'
'a910809a823ba58ca7bdaa72e8d68427b48f452c1fbb2343fa182ecb0a091a7640e73af24b8ba2fdd90e00aed8ef53b7fccd25cb8f04ca9b9fa6c8e52223ca66')
provides=('netdata')
conflicts=('netdata')
@@ -40,7 +45,8 @@ install="$_gitname.install"
prepare() {
cd "$_gitname"
git submodule set-url mqtt_websockets "$srcdir"/submodule-mqtt_websockets
- git submodule update --init --no-fetch mqtt_websockets
+ git submodule set-url aclk/aclk-schemas "$srcdir"/submodule-aclk-schemas
+ git submodule update --init --no-fetch mqtt_websockets aclk/aclk-schemas
git -C mqtt_websockets submodule set-url MQTT-C "$srcdir"/submodule-MQTT-C
git -C mqtt_websockets submodule set-url c-rbuf "$srcdir"/submodule-c-rbuf
@@ -72,16 +78,10 @@ package() {
make DESTDIR="$pkgdir" install
- # Remove /var/*, pacman creates it via tmpfiles hook
- rm -vrf "${pkgdir}/var"
-
- mkdir -p "$pkgdir/etc/netdata"
- chown -R 134:134 "$pkgdir"/etc/netdata
- chown -R 134:134 "$pkgdir"/usr/share/netdata/web
+ install -Dm644 system/netdata.conf "$pkgdir"/etc/netdata/netdata.conf
+ chown -R 0:134 "$pkgdir"/usr/share/netdata/web
- install -Dm0644 "system/netdata.service" "$pkgdir/usr/lib/systemd/system/netdata.service"
+ install -Dm0644 "system/netdata.service.v235" "$pkgdir/usr/lib/systemd/system/netdata.service"
install -Dm0644 "system/netdata.logrotate" "$pkgdir/etc/logrotate.d/netdata"
- install -Dm0644 "${srcdir}/${_gitname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${_gitname}.conf"
install -Dm0644 "${srcdir}/${_gitname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_gitname}.conf"
}
-
diff --git a/netdata.tmpfiles b/netdata.tmpfiles
deleted file mode 100644
index 85d4252264cf..000000000000
--- a/netdata.tmpfiles
+++ /dev/null
@@ -1,3 +0,0 @@
-d /var/lib/netdata 0750 netdata netdata
-d /var/log/netdata 0750 netdata netdata
-d /var/cache/netdata 0750 netdata netdata