summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-11-26 23:12:49 -0500
committeréclairevoyant2022-11-26 23:12:49 -0500
commit03379c03469953a8b4a4ef802071b8b5208d32d2 (patch)
tree28fe83b8c9d426eb0721657c24a88f7e184bb7a1
parent9b44e9266bdd2643608e2740ef737fc4553914b9 (diff)
downloadaur-03379c03469953a8b4a4ef802071b8b5208d32d2.tar.gz
clean up deps, patches, versioning
add .gitignore Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD69
-rw-r--r--ffmpeg5.patch13
4 files changed, 61 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 859573a6a5f7..9dbaf3b7c144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,46 @@
pkgbase = digikam-git
pkgdesc = An advanced digital photo management application
- pkgver = v7.5.0.r345.g61141c0787
+ pkgver = 7.5.0.r4063.gdcef37cf0d
pkgrel = 1
url = https://www.digikam.org/
arch = i686
arch = x86_64
license = GPL
- makedepends = extra-cmake-modules
+ makedepends = boost
makedepends = doxygen
makedepends = eigen
- makedepends = boost
+ makedepends = extra-cmake-modules
+ makedepends = git
makedepends = kdoctools
- depends = lensfun
- depends = opencv
depends = akonadi-contacts
+ depends = exiv
+ depends = glu
+ depends = imagemagick
+ depends = jasper
+ depends = kcalendarcore
+ depends = kfilemetadata
+ depends = kio
depends = knotifyconfig
+ depends = lensfun
+ depends = libass
+ depends = libgphoto2
depends = libksane
- depends = kfilemetadata
- depends = qtav
depends = marble-common
- depends = threadweaver
- depends = kcalendarcore
- depends = qt5-xmlpatterns
- depends = imagemagick
- depends = jasper
- depends = glu
+ depends = opencv
depends = perl-image-exiftool
- optdepends = hugin: panorama tool
- optdepends = qt5-imageformats: support for additional image formats (WEBP, TIFF)
- optdepends = rawtherapee: RAW import
+ depends = qt5-networkauth
+ depends = qt5-webengine
+ depends = qt5-xmlpatterns
+ depends = qtav
+ depends = threadweaver
optdepends = darktable: RAW import
+ optdepends = hugin: panorama tool
optdepends = perl: for digitaglinktree
+ optdepends = qt5-imageformats: TIFF, WEBP support
+ optdepends = rawtherapee: RAW import
provides = digikam
conflicts = digikam
source = git+https://invent.kde.org/graphics/digikam.git
- source = ffmpeg5.patch
sha256sums = SKIP
- sha256sums = ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee
pkgname = digikam-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 77eb4d598af5..2314124a2f14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,48 @@
-# Maintainer: Anthony Wang <ta180m at pm dot me>
+# Maintainer: éclairevoyant
+# Contributor: Anthony Wang <ta180m at pm dot me>
# Contributor: Chris Lane <aur at chrislane dot com>
+
_pkgname=digikam
-pkgname=digikam-git
-pkgver=v7.5.0.r345.g61141c0787
+pkgname="$_pkgname-git"
+pkgver=7.5.0.r4063.gdcef37cf0d
pkgrel=1
pkgdesc='An advanced digital photo management application'
-arch=(i686 x86_64)
-license=(GPL)
+arch=('i686' 'x86_64')
+license=('GPL')
url='https://www.digikam.org/'
-depends=(lensfun opencv akonadi-contacts knotifyconfig libksane kfilemetadata qtav marble-common threadweaver kcalendarcore
- qt5-xmlpatterns imagemagick jasper glu perl-image-exiftool)
-makedepends=(extra-cmake-modules doxygen eigen boost kdoctools)
-optdepends=('hugin: panorama tool' 'qt5-imageformats: support for additional image formats (WEBP, TIFF)'
- 'rawtherapee: RAW import' 'darktable: RAW import'
- 'perl: for digitaglinktree')
-conflicts=('digikam')
-provides=('digikam')
-source=('git+https://invent.kde.org/graphics/digikam.git'
- ffmpeg5.patch)
-sha256sums=('SKIP'
- 'ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee')
+depends=('akonadi-contacts' 'exiv' 'glu' 'imagemagick' 'jasper' 'kcalendarcore'
+ 'kfilemetadata' 'kio' 'knotifyconfig' 'lensfun' 'libass' 'libgphoto2'
+ 'libksane' 'marble-common' 'opencv' 'perl-image-exiftool'
+ 'qt5-networkauth' 'qt5-webengine' 'qt5-xmlpatterns' 'qtav'
+ 'threadweaver')
+makedepends=('boost' 'doxygen' 'eigen' 'extra-cmake-modules' 'git' 'kdoctools')
+optdepends=('darktable: RAW import'
+ 'hugin: panorama tool'
+ 'perl: for digitaglinktree'
+ 'qt5-imageformats: TIFF, WEBP support'
+ 'rawtherapee: RAW import')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://invent.kde.org/graphics/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
- cd ${_pkgname}
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- patch -d ${_pkgname} -p1 < ffmpeg5.patch
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cmake -B build -S ${_pkgname} \
- -DBUILD_TESTING=OFF \
- -DENABLE_KFILEMETADATASUPPORT=ON \
- -DENABLE_MEDIAPLAYER=ON \
- -DENABLE_AKONADICONTACTSUPPORT=ON \
- -DENABLE_MYSQLSUPPORT=ON \
- -DENABLE_APPSTYLES=ON \
- -DENABLE_QWEBENGINE=ON
- cmake --build build
+ cmake -B build -S $_pkgname \
+ -DBUILD_TESTING=OFF \
+ -DENABLE_KFILEMETADATASUPPORT=ON \
+ -DENABLE_MEDIAPLAYER=ON \
+ -DENABLE_AKONADICONTACTSUPPORT=ON \
+ -DENABLE_MYSQLSUPPORT=ON \
+ -DENABLE_APPSTYLES=ON \
+ -DENABLE_QWEBENGINE=ON
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/ffmpeg5.patch b/ffmpeg5.patch
deleted file mode 100644
index cbdd368b38a2..000000000000
--- a/ffmpeg5.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/core/libs/threadimageio/video/videodecoder_p.h b/core/libs/threadimageio/video/videodecoder_p.h
-index 251e092809..d82926b77e 100644
---- a/core/libs/threadimageio/video/videodecoder_p.h
-+++ b/core/libs/threadimageio/video/videodecoder_p.h
-@@ -56,7 +56,7 @@ public:
- AVFormatContext* pFormatContext;
- AVCodecContext* pVideoCodecContext;
- AVCodecParameters* pVideoCodecParameters;
-- AVCodec* pVideoCodec;
-+ const AVCodec* pVideoCodec;
- AVStream* pVideoStream;
- AVFrame* pFrame;
- quint8* pFrameBuffer;