summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Démoulins2016-02-24 15:29:49 +0100
committerClément Démoulins2016-02-24 15:29:49 +0100
commit03452291006ff49380c30d609d7ac42503048e43 (patch)
treeec74570aa2de5928c198ad5c6de144a077a9d250
parent54d858107aa6338ffda34abfb79d8dcddabce93f (diff)
downloadaur-03452291006ff49380c30d609d7ac42503048e43.tar.gz
Add check function to do a simple check
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bc643e46a3b..0a17ea8baf71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Feb 23 14:29:03 UTC 2016
+# Wed Feb 24 14:29:44 UTC 2016
pkgbase = vcsn
pkgdesc = Finite state machine manipulation platform, consisting of a library and tools implemented on top of it.
pkgver = 2.2
diff --git a/PKGBUILD b/PKGBUILD
index 903e7eda25fb..b28e4cb46988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,11 @@ options=(!buildflags)
source=("https://www.lrde.epita.fr/dload/vcsn/$pkgver/$pkgname-$pkgver.tar.xz")
md5sums=('48e479d34a047df4507d1e7b322bfb16')
+check() {
+ cd "$srcdir/${_realname}"
+ ./tests/bin/vcsn python -c 'import vcsn; vcsn.B.expression("a").automaton()'
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix="/usr" CXXFLAGS='-O3' CPPFLAGS='-DNDEBUG'