summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjaro Build Server2023-04-04 08:50:15 -0600
committerManjaro Build Server2023-04-04 08:50:15 -0600
commit035a4f801afc876c67ccacec563542f88ea3c943 (patch)
tree3533f5f2c873b52ab73106d57342b84b312bc3f9
parentdce18e34ef808e7cbf17fe2cca066cbe8b9bed46 (diff)
downloadaur-035a4f801afc876c67ccacec563542f88ea3c943.tar.gz
1.19.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20995ae1d441..85e982ef1977 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sentry_sdk
pkgdesc = The new Python SDK for Sentry.io
- pkgver = 1.18.0
+ pkgver = 1.19.0
pkgrel = 1
url = https://sentry.io/for/python
arch = any
@@ -21,6 +21,7 @@ pkgbase = python-sentry_sdk
optdepends = python-falcon: adds support for the Falcon Web Framework
optdepends = python-fastapi: adds support for the FastAPI framework
optdepends = python-flask: adds support for the Flask Web Framework
+ optdepends = python-grpcio: gRPC integration
optdepends = python-httpx: HTTPX integration
optdepends = python-huey: Huey Integration
optdepends = python-multipart: Optional dependency of Starlette to parse form data
@@ -39,7 +40,7 @@ pkgbase = python-sentry_sdk
optdepends = python-trytond: adds support for the Tryton Framework Server
optdepends = python-pure_eval: for richer stacktraces & additional variables
optdepends = python-executing: for richer stacktraces & better function names
- source = https://files.pythonhosted.org/packages/source/s/sentry-sdk/sentry-sdk-1.18.0.tar.gz
- sha256sums = d07b9569a151033b462f7a7113ada94cc41ecf49daa83d35f5f852a0b9cf3b44
+ source = https://files.pythonhosted.org/packages/source/s/sentry-sdk/sentry-sdk-1.19.0.tar.gz
+ sha256sums = 6732b59a55051646587acce21f6a00b53d05df9282d54886ad88b59b4e9b82ad
pkgname = python-sentry_sdk
diff --git a/PKGBUILD b/PKGBUILD
index 240efa9ea7cc..d2fa7253d9e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=1.18.0
+pkgver=1.19.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -19,6 +19,7 @@ optdepends=('python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
'python-falcon: adds support for the Falcon Web Framework'
'python-fastapi: adds support for the FastAPI framework'
'python-flask: adds support for the Flask Web Framework'
+ 'python-grpcio: gRPC integration'
'python-httpx: HTTPX integration'
'python-huey: Huey Integration'
'python-multipart: Optional dependency of Starlette to parse form data'
@@ -38,7 +39,7 @@ optdepends=('python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
'python-pure_eval: for richer stacktraces & additional variables'
'python-executing: for richer stacktraces & better function names')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('d07b9569a151033b462f7a7113ada94cc41ecf49daa83d35f5f852a0b9cf3b44')
+sha256sums=('6732b59a55051646587acce21f6a00b53d05df9282d54886ad88b59b4e9b82ad')
build() {
cd "$_name-$pkgver"