summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2019-11-02 00:07:57 +0800
committerpeeweep2019-11-02 00:07:57 +0800
commit035d5c7359783996ccb55f2752be45bed0e0e9b0 (patch)
tree1a894b5efc502cf3823b45139040d73999c0bc00
parentf1703a8c1257caf022cfff10d5659d67fab9af65 (diff)
downloadaur-035d5c7359783996ccb55f2752be45bed0e0e9b0.tar.gz
bumper version 2.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD10
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a31a82031fc..9139754fb174 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Nov 8 19:59:30 UTC 2016
pkgbase = muduo
pkgdesc = A C++ non-blocking multi-threaded network library
- pkgver = 1.0.9
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/chenshuo/muduo
arch = i686
@@ -12,8 +10,8 @@ pkgbase = muduo
makedepends = boost
depends = protobuf
options = staticlibs
- source = muduo-1.0.9.zip::https://github.com/chenshuo/muduo/archive/v1.0.9.zip
- sha1sums = 3ae5a3727cbd45bf4795a97768d577a193792b61
+ source = muduo-2.0.0.zip::https://github.com/chenshuo/muduo/archive/v2.0.0.zip
+ sha1sums = ba73e559a060479550167694e6b939a97ea6fec4
pkgname = muduo
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7a210d1ef85b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+*.zip
+*.log
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 41f00d32ecba..16ba19f487a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Anatol Pomozov <anatol@google.com>
pkgname=muduo
-pkgver=1.0.9
+pkgver=2.0.0
pkgrel=1
pkgdesc='A C++ non-blocking multi-threaded network library'
url='https://github.com/chenshuo/muduo'
@@ -11,15 +11,17 @@ depends=(protobuf)
makedepends=(cmake boost)
options=(staticlibs)
source=(muduo-$pkgver.zip::https://github.com/chenshuo/muduo/archive/v$pkgver.zip)
-sha1sums=('3ae5a3727cbd45bf4795a97768d577a193792b61')
+sha1sums=('ba73e559a060479550167694e6b939a97ea6fec4')
build() {
cd muduo-$pkgver
sed -i '/-Werror/d' CMakeLists.txt
- BUILD_NO_EXAMPLES=1 INSTALL_DIR=/usr ./build.sh
+ sed -i 's/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" ON/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" OFF/' CMakeLists.txt
+ INSTALL_DIR=/usr ./build.sh
}
package() {
- cd build/release
+ cd build/release-cpp11
make install DESTDIR="$pkgdir"
+ install -Dm644 "${srcdir}/${pkgname}-$pkgver/License" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}