summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-11-08 00:34:19 +0100
committerKr1ss2019-11-08 00:34:19 +0100
commit0374f6bd1240bbf907616815b71cb1dcbfb3e5db (patch)
treee4552942295de50ebfac0e3605043249997d169e
parent5fdc21ea294eb8ff8da4199ddca2492de5a2ad2b (diff)
downloadaur-0374f6bd1240bbf907616815b71cb1dcbfb3e5db.tar.gz
implement dynamic python version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cd9adafd0d7..f441df5507f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pystache-git
pkgdesc = The mustache template engine written in python
pkgver = 0.5.4.r3.17a5dfd
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/defunkt/pystache
changelog = history
diff --git a/PKGBUILD b/PKGBUILD
index 02a08e1c2791..1ffa723238b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
pkgver=0.5.4.r3.17a5dfd
-pkgrel=1
+pkgrel=2
pkgdesc="The mustache template engine written in python"
arch=('x86_64')
@@ -41,7 +41,8 @@ check() {
mkdir test_dir
cd "$_pkgname"
python setup.py install --root=../test_dir
- PYTHONPATH=../test_dir/usr/lib/python3.7/site-packages/ \
+ _py3ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
+ PYTHONPATH="../test_dir/usr/lib/python$_py3ver/site-packages/" \
../test_dir/usr/bin/pystache-test .
}