summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2016-10-13 16:52:49 +0200
committerJoost Bremmer2016-10-13 16:52:49 +0200
commit037e45a2f88ff61cf21f7a2e869a492caa76617b (patch)
tree644dc6fc9f7465fea4978f5d760beea98df0a1e3
downloadaur-037e45a2f88ff61cf21f7a2e869a492caa76617b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD24
-rw-r--r--neovim-plug.init.vim27
-rw-r--r--neovim-plug.install17
5 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1648738a763
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-plug
+ pkgdesc = A Neovim plugin manager
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = http://github.com/junegunn/neovim-plug
+ install = neovim-plug.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim
+ source = https://github.com/junegunn/vim-plug/archive/0.7.2.tar.gz
+ source = neovim-plug.init.vim
+ sha512sums = c9d2954ad8501390e5c72ddefa4b2ff75843b850a5f330580c347ff9186e3e30c0bcd42bedd1381cf4ea55532a08e4d757b7a89d61726f9e1d38729631c24e78
+ sha512sums = 8e15c2074d0ce36daa0568167bcbcaf1038b8f65edcab661c9d41a9a18714b27accab28f5065408852329827ff4c84c03102c17bd542962cde1f057e88c4044c
+
+pkgname = neovim-plug
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a167c9bba40d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joost Bremmer <toost.b@gmail.com>
+# Contributor: oozyslug <oozyslug at gmail dot com>
+
+pkgname=neovim-plug
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A Neovim plugin manager"
+arch=('any')
+url="http://github.com/junegunn/neovim-plug"
+license=('MIT')
+depends=('neovim')
+groups=('neovim-plugins')
+source=("https://github.com/junegunn/${pkgname#neo}/archive/$pkgver.tar.gz"
+ "$pkgname.init.vim")
+
+sha512sums=('c9d2954ad8501390e5c72ddefa4b2ff75843b850a5f330580c347ff9186e3e30c0bcd42bedd1381cf4ea55532a08e4d757b7a89d61726f9e1d38729631c24e78'
+ '8e15c2074d0ce36daa0568167bcbcaf1038b8f65edcab661c9d41a9a18714b27accab28f5065408852329827ff4c84c03102c17bd542962cde1f057e88c4044c')
+install=neovim-plug.install
+
+package() {
+ install -Dm 644 ${pkgname#neo}-${pkgver}/plug.vim ${pkgdir}/usr/share/nvim/runtime/autoload/plug.vim
+ install -Dm 644 "$pkgname.init.vim" ${pkgdir}/usr/share/doc/neovim-plug/init.vim.sample
+}
+# vim: set ts=2 sw=2 et:
diff --git a/neovim-plug.init.vim b/neovim-plug.init.vim
new file mode 100644
index 000000000000..094d5e442fa1
--- /dev/null
+++ b/neovim-plug.init.vim
@@ -0,0 +1,27 @@
+call plug#begin('~/.vim/plugged')
+
+" Make sure you use single quotes
+ Plug 'junegunn/seoul256.vim'
+ Plug 'junegunn/vim-easy-align'
+
+" Group dependencies, vim-snippets depends on ultisnips
+ Plug 'SirVer/ultisnips' | Plug 'honza/vim-snippets'
+
+" On-demand loading
+ Plug 'scrooloose/nerdtree', { 'on': 'NERDTreeToggle' }
+ Plug 'tpope/vim-fireplace', { 'for': 'clojure' }
+
+" Using git URL
+ Plug 'https://github.com/junegunn/vim-github-dashboard.git'
+
+" Plugin options
+ Plug 'nsf/gocode', { 'tag': 'v.20150303', 'rtp': 'vim' }
+
+" Plugin outside ~/.vim/plugged with post-update hook
+ Plug 'junegunn/fzf', { 'dir': '~/.fzf', 'do': 'yes \| ./install' }
+
+" Unmanaged plugin (manually installed and updated)
+ Plug '~/my-prototype-plugin'
+
+call plug#end()
+
diff --git a/neovim-plug.install b/neovim-plug.install
new file mode 100644
index 000000000000..bbfc29867a8e
--- /dev/null
+++ b/neovim-plug.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo "
+ >>> To use vim-plug, please check the file /usr/share/doc/neovim-plug/init.vim.sample
+ >>> and update your init.vim file, accordingly
+ "
+}
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo "
+ >>> Please remember to remove plugins from your init.vim file
+ >>> and from your plugin directory!
+ "
+}
+