summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-10-01 08:41:07 +0300
committerDimitris Kiziridis2020-10-01 08:41:07 +0300
commit038b3db810e4a825351f6ac1879f2e044a72ff17 (patch)
tree3e02bf777137705409ceab73983766fa1ab7797d
parentda91e2a5f4d5b3342de6d4b9d903249b5ec5b5db (diff)
downloadaur-038b3db810e4a825351f6ac1879f2e044a72ff17.tar.gz
default to lua 5.4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9100b0595405..218bee22a8e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,7 @@ pkgbase = lua-discount
sha256sums = 8b2fffc6b27a33bf6958a2a2293ce19ce5cbd7206ccb6dda7a9d3abe6f80c9fa
pkgname = lua-discount
- pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.3
+ pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.4
pkgname = lua51-discount
pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.1
@@ -23,3 +23,6 @@ pkgname = lua51-discount
pkgname = lua52-discount
pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.2
+pkgname = lua53-discount
+ pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 132e5bf938df..b0ebaad15774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-pkgname=('lua-discount' 'lua51-discount' 'lua52-discount')
+pkgname=('lua-discount' 'lua51-discount' 'lua52-discount' 'lua53-discount')
pkgver=0.4
pkgrel=1
pkgdesc="Lua bindings for the Discount Markdown library"
@@ -24,7 +24,7 @@ prepare() {
}
build() {
- mkdir -p 5.1 5.2 5.3
+ mkdir -p 5.1 5.2 5.3 5.4
# Build for 5.1
(cd 5.1; luarocks build --pack-binary-rock --lua-version=5.1 --deps-mode=none ../lua-discount-${pkgver}/"discount-$pkgver-1.rockspec")
@@ -32,9 +32,20 @@ build() {
(cd 5.2; luarocks build --pack-binary-rock --lua-version=5.2 --deps-mode=none ../lua-discount-${pkgver}/"discount-$pkgver-1.rockspec")
# Build for 5.3
(cd 5.3; luarocks build --pack-binary-rock --lua-version=5.3 --deps-mode=none ../lua-discount-${pkgver}/"discount-$pkgver-1.rockspec")
+ # Build for 5.4
+ (cd 5.4; luarocks build --pack-binary-rock --lua-version=5.4 --deps-mode=none ../lua-discount-${pkgver}/"discount-$pkgver-1.rockspec")
}
package_lua-discount() {
+ pkgdesc='Lua bindings for the Discount Markdown library for Lua 5.4'
+
+ luarocks install --lua-version=5.4 --tree="$pkgdir/usr/" --deps-mode=none 5.4/*.rock
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # remove luarocks-created root manifest
+ rm "$pkgdir/usr/lib/luarocks/rocks-5.4/manifest"
+}
+
+package_lua53-discount() {
pkgdesc='Lua bindings for the Discount Markdown library for Lua 5.3'
luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/*.rock