summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2021-10-09 21:17:08 +0200
committerMichał Walenciak2021-10-09 21:17:08 +0200
commit039113f4f6d4971fcaefc0231c4c24f74836ad67 (patch)
treeb3cc2be96edaea0bcda776d13a1069971361dbbe
parent1a38b694427b6300d3fe8b7c5ccd2c8d14530a6d (diff)
downloadaur-039113f4f6d4971fcaefc0231c4c24f74836ad67.tar.gz
bumping version to 0.8.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dbad82c38de..82d325793c2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = openblok
pkgdesc = A customizable, cross platform, open-source falling block game, packed with a bunch of features.
- pkgver = 0.8.2
- pkgrel = 3
+ pkgver = 0.8.3
+ pkgrel = 1
url = https://github.com/mmatyas/openblok
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- makedepends = gcc8
depends = sdl2
depends = sdl2_image
depends = sdl2_mixer
depends = sdl2_ttf
- source = https://codeload.github.com/mmatyas/openblok/tar.gz/v0.8.2
- source = libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#branch=cmake_modernization
- md5sums = 6dd426a1dec30c74036ae09113505659
+ source = https://codeload.github.com/mmatyas/openblok/tar.gz/v0.8.3
+ source = libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#commit=4cb0e063ddd7db666007c71cef7a5f9cce866671
+ md5sums = e3704fbdd4451255efc6772046a12dd0
md5sums = SKIP
pkgname = openblok
-
diff --git a/PKGBUILD b/PKGBUILD
index a08dc62d0964..3f66b09a5c0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=openblok
-pkgver=0.8.2
-pkgrel=3
+pkgver=0.8.3
+pkgrel=1
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
@@ -11,7 +11,7 @@ depends=('sdl2'
'sdl2_image'
'sdl2_mixer'
'sdl2_ttf')
-makedepends=('cmake' 'gcc8')
+makedepends=('cmake')
optdepends=()
provides=()
conflicts=()
@@ -20,9 +20,9 @@ backup=()
options=()
install=
changelog=
-source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#branch=cmake_modernization)
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#commit=4cb0e063ddd7db666007c71cef7a5f9cce866671)
noextract=()
-md5sums=('6dd426a1dec30c74036ae09113505659'
+md5sums=('e3704fbdd4451255efc6772046a12dd0'
'SKIP')
prepare()
@@ -36,7 +36,7 @@ build()
cd $pkgname-$pkgver
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin -DCMAKE_CXX_COMPILER=c++-8 -DCMAKE_C_COMPILER=gcc-8 ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin ..
make
}