summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianqiu Zhang2018-07-20 09:25:42 +0800
committerJianqiu Zhang2018-07-20 09:28:57 +0800
commit03a1e60abb09ef534d3d6e99923a466cc13e23a3 (patch)
tree788d4f04646d47d9eaa7b68e47bf8c90bdfcbb7f
downloadaur-03a1e60abb09ef534d3d6e99923a466cc13e23a3.tar.gz
release kcm-colorful-git
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3a301953fc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kcm-colorful-git
+ pkgdesc = Make your KDE plasma colorful
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/IsoaSFlus/kcm-colorful
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = qt5-base
+ makedepends = frameworkintegration
+ makedepends = kcmutils
+ depends = kconfigwidgets
+ source = kcm-colorful::git+https://github.com/IsoaSFlus/kcm-colorful
+ sha256sums = SKIP
+
+pkgname = kcm-colorful-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd9a3a51b271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jianqiu Zhang <void001@archlinuxcn.org>
+
+
+pkgname=kcm-colorful-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Make your KDE plasma colorful'
+arch=('x86_64')
+url="https://github.com/IsoaSFlus/kcm-colorful"
+license=('GPL2')
+depends=('kconfigwidgets')
+makedepends=('cmake' 'git' 'extra-cmake-modules' 'qt5-base' 'frameworkintegration' 'kcmutils')
+
+source=(
+ "kcm-colorful::git+https://github.com/IsoaSFlus/kcm-colorful"
+)
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd $srcdir/kcm-colorful
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd $srcdir/kcm-colorful
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
+ make
+}
+
+package() {
+ cd $srcdir/kcm-colorful/build
+ make install
+}