summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 22:05:36 +0100
committerGianluca Boiano2021-02-28 22:05:36 +0100
commit03ca9beb22a6bac36e8094f875e6ea6ecf54abc4 (patch)
treed362c14bc9fe733a5d05d2b1ffae2880e25c33a0
parent363dbdecfee5b7d967611d1bf5187890194cd0cc (diff)
downloadaur-03ca9beb22a6bac36e8094f875e6ea6ecf54abc4.tar.gz
ocaml-duppy: fix dune compilation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f28327d95ed9..344c7fd561e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ocaml-duppy
pkgdesc = OCaml asynchronous scheduler and monad for server-oriented programming
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/savonet/ocaml-duppy
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = ocaml-findlib
makedepends = dune
depends = ocaml
depends = ocaml-pcre
diff --git a/PKGBUILD b/PKGBUILD
index e77eeafd4c56..b77ada3b2ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
pkgname=ocaml-duppy
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="OCaml asynchronous scheduler and monad for server-oriented programming"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-duppy"
license=('LGPL2.1')
depends=('ocaml' 'ocaml-pcre')
-makedepends=('dune')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
source=("https://github.com/savonet/ocaml-duppy/archive/v${pkgver}.tar.gz")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
dune build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
sha256sums=('e5674cb25d53e0f871106489067422e6e9daa4225cc0669bdeab11b6e7cb2fbc')