summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahdi Sarikhani2024-01-29 01:58:38 +0330
committerMahdi Sarikhani2024-01-29 01:58:38 +0330
commit03cb85a76a5444977822c0a4b400fe7d28097f2f (patch)
treed587e848115b9909d96fc50cd709c6f13afe9be8
parent41f32386a06bda7e11b291662b380360d90afbf3 (diff)
downloadaur-03cb85a76a5444977822c0a4b400fe7d28097f2f.tar.gz
v0.81
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--ttf-sudo.install14
3 files changed, 14 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b279051fae..4424a3bf9163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = ttf-sudo
pkgdesc = A font for programmers and command line users
- pkgver = 0.50
+ pkgver = 0.81
pkgrel = 1
url = https://www.kutilek.de/sudo-font/
- install = ttf-sudo.install
arch = any
- license = SIL
- depends = fontconfig
- depends = xorg-font-utils
- source = https://github.com/jenskutilek/sudo-font/archive/v0.50.tar.gz
- md5sums = 0cca8420448f28489564993bdbd3706c
+ license = OFL-1.1
+ source = https://github.com/jenskutilek/sudo-font/releases/download/v0.81/sudo.zip
+ sha256sums = 7cb85250db95899ce9f894ff5559c71fe77ba8c6c7abbfaabec869d847963764
pkgname = ttf-sudo
-
diff --git a/PKGBUILD b/PKGBUILD
index b2e6582e0158..6bed2259c08f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: Will Price <will.price94@gmail.com>
+# Maintainer: Mahdi Sarikhani <mahdisarikhani@outlook.com>
+# Contributor: Will Price <will.price94@gmail.com>
pkgname=ttf-sudo
-pkgver=0.50
+pkgver=0.81
pkgrel=1
pkgdesc="A font for programmers and command line users"
-arch=(any)
+arch=('any')
url="https://www.kutilek.de/sudo-font/"
-license=(SIL)
-install=ttf-sudo.install
-depends=(fontconfig xorg-font-utils)
-source=("https://github.com/jenskutilek/sudo-font/archive/v${pkgver}.tar.gz")
-md5sums=('0cca8420448f28489564993bdbd3706c')
+license=('OFL-1.1')
+source=("https://github.com/jenskutilek/sudo-font/releases/download/v${pkgver}/sudo.zip")
+sha256sums=('7cb85250db95899ce9f894ff5559c71fe77ba8c6c7abbfaabec869d847963764')
package() {
- for font in "$srcdir/sudo-font-$pkgver/sudo/"Sudo*.ttf; do
- install -Dm644 "$font" \
- "$pkgdir/usr/share/fonts/sudo-font/$(basename "$font")"
- done
+ cd sudo
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" OFL.txt
}
# vim:set ts=2 sw=2 et:
diff --git a/ttf-sudo.install b/ttf-sudo.install
deleted file mode 100644
index c3131bc89c16..000000000000
--- a/ttf-sudo.install
+++ /dev/null
@@ -1,14 +0,0 @@
-_update_fonts() {
- echo "Rescaning system to build font cache"
- fc-cache --force --system-only
-}
-
-post_install() {
- _update_fonts
-}
-
-post_upgrade() {
- _update_fonts
-}
-
-# vim:set ts=2 sw=2 et: