summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-07 20:51:22 +0000
committerDaniel Bermond2020-10-07 20:51:22 +0000
commit03d179fed9431a434d69d212657be0f13c46b38d (patch)
tree4199a608492aeb459a120238a817a40535247361
parent282f0f53ea6530259fb57f5239c3dca08b7a6a79 (diff)
downloadaur-03d179fed9431a434d69d212657be0f13c46b38d.tar.gz
Update tbb patch. Download git lfs files.
-rw-r--r--.SRCINFO5
-rw-r--r--030-intel-openvino-do-not-install-tbb.patch4
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 321a79c61aea..f35f3a79d07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = intel-openvino-git
pkgdesc = Toolkit for developing applications and solutions that emulate human vision using Intel hardware (git version)
- pkgver = 2020.2.r564.g73ee68afb
+ pkgver = 2020.2.r1348.g8062f20c1
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
license = Apache
makedepends = git
+ makedepends = git-lfs
makedepends = cmake
makedepends = python
makedepends = cython
@@ -47,7 +48,7 @@ pkgbase = intel-openvino-git
sha256sums = 093199ae759e8755166b9737562438866123eda9b1afbbef2f7107b3cf827be5
sha256sums = 502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0
sha256sums = b58aa9ec526cb6c528c58fc8b1a1b93b425999d1de29f0dd15a8b680c9eb8c77
- sha256sums = 806a8fd32f45e03d88e22f171fc831a319a1ef78c9da6b0700ca8ef43cb7a94d
+ sha256sums = f7e6616ef15c6252dbad9f13b446ec36b675b29e5b93ab34f8b136d7218a4150
pkgname = intel-openvino-git
diff --git a/030-intel-openvino-do-not-install-tbb.patch b/030-intel-openvino-do-not-install-tbb.patch
index feb4646939ad..4e0df095e6c8 100644
--- a/030-intel-openvino-do-not-install-tbb.patch
+++ b/030-intel-openvino-do-not-install-tbb.patch
@@ -1,10 +1,10 @@
--- a/inference-engine/src/inference_engine/CMakeLists.txt
+++ b/inference-engine/src/inference_engine/CMakeLists.txt
-@@ -230,30 +230,6 @@ ie_developer_export_targets(${TARGET_NAME} ${TARGET_NAME}_plugin_api xbyak)
+@@ -240,30 +240,6 @@ ie_developer_export_targets(${TARGET_NAME} ${TARGET_NAME}_plugin_api xbyak)
list(APPEND core_components ngraph)
--if(THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
+-if((THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO") AND TBBROOT MATCHES ${TEMP})
- ie_cpack_add_component(tbb REQUIRED)
- list(APPEND core_components tbb)
-
diff --git a/PKGBUILD b/PKGBUILD
index 15f41f94b30b..27545a7cad11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=intel-openvino-git
-pkgver=2020.2.r564.g73ee68afb
+pkgver=2020.2.r1348.g8062f20c1
pkgrel=1
pkgdesc='Toolkit for developing applications and solutions that emulate human vision using Intel hardware (git version)'
arch=('x86_64')
@@ -14,11 +14,11 @@ optdepends=('python: for using the Python API'
'python-py-cpuinfo: for running the benchmark tool'
'python-progress: for running the benchmark tool'
'opencv: for running the benchmark tool')
-makedepends=('git' 'cmake' 'python' 'cython' 'opencv' 'aria2' 'wget')
+makedepends=('git' 'git-lfs' 'cmake' 'python' 'cython' 'opencv' 'aria2' 'wget')
provides=('intel-openvino')
conflicts=('intel-openvino')
options=('!emptydirs')
-source=("git+https://github.com/openvinotoolkit/openvino.git"
+source=('git+https://github.com/openvinotoolkit/openvino.git'
'git+https://github.com/opencv/ade.git'
'git+https://github.com/openvinotoolkit/oneDNN.git'
'googletest-openvinotoolkit'::'git+https://github.com/openvinotoolkit/googletest.git'
@@ -39,9 +39,14 @@ sha256sums=('SKIP'
'093199ae759e8755166b9737562438866123eda9b1afbbef2f7107b3cf827be5'
'502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0'
'b58aa9ec526cb6c528c58fc8b1a1b93b425999d1de29f0dd15a8b680c9eb8c77'
- '806a8fd32f45e03d88e22f171fc831a319a1ef78c9da6b0700ca8ef43cb7a94d')
+ 'f7e6616ef15c6252dbad9f13b446ec36b675b29e5b93ab34f8b136d7218a4150')
+
+export GIT_LFS_SKIP_SMUDGE='1'
prepare() {
+ git -C openvino lfs install --local
+ git -C openvino lfs pull "${source[0]/git+/}"
+
git -C openvino submodule init
git -C openvino config --local submodule.inference-engine/thirdparty/ade.url "${srcdir}/ade"
git -C openvino config --local submodule.inference-engine/thirdparty/mkl-dnn.url "${srcdir}/oneDNN"