summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2018-03-05 20:26:34 +0100
committerRaimar Bühmann2018-03-05 20:26:34 +0100
commit03fa59bf2f21dfd5e34ea6837e9e8c80ab9306d0 (patch)
tree20556ea8c7fb7bb3f33a970127b38cef58c65ef8
parent351e864950604c70b69f226abc419f2ed1d7e833 (diff)
downloadaur-03fa59bf2f21dfd5e34ea6837e9e8c80ab9306d0.tar.gz
remove libankidrive-git
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b25670074ed..d9ad11e56bb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,19 @@
pkgbase = anki-drive-sdk-git
+ pkgdesc = C SDK for message protocols and data parsing to communicate with Anki Drive vehicles
pkgver = 0.3.0.r40.20180115
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/anki/drive-sdk
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
makedepends = gcc
+ depends = glib2
optdepends = bluez-utils: for command line tool btmgmt (hciconfig is deprecated)
+ conflicts = libankidrive
+ replaces = libankidrive
source = anki-drive-sdk-git::git+https://github.com/anki/drive-sdk.git
md5sums = SKIP
pkgname = anki-drive-sdk-git
- pkgdesc = C SDK for message protocols and data parsing to communicate with Anki Drive vehicles
- depends = libankidrive
-
-pkgname = libankidrive-git
- pkgdesc = C library of message protocols and data parsing to communicate with Anki Drive vehicles
- depends = glib2
- provides = libankidrive
- conflicts = libankidrive
- replaces = libankidrive
diff --git a/PKGBUILD b/PKGBUILD
index ea8cd71264b2..bb477ce41609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,17 @@
# Maintainer: Raimar Bühmann <raimar _at_ buehmann _dot_ de>
-pkgname=('anki-drive-sdk-git' 'libankidrive-git')
+pkgname=('anki-drive-sdk-git')
+pkgdesc="C SDK for message protocols and data parsing to communicate with Anki Drive vehicles"
pkgver=0.3.0.r40.20180115
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://github.com/anki/drive-sdk"
license=('Apache')
+depends=('glib2')
optdepends=('bluez-utils: for command line tool btmgmt (hciconfig is deprecated)')
makedepends=('cmake' 'gcc')
+conflicts=('libankidrive')
+replaces=('libankidrive')
source=(
"$pkgname::git+https://github.com/anki/drive-sdk.git"
)
@@ -34,25 +38,12 @@ build() {
cmake .. -DCMAKE_INSTALL_PREFIX= -DBUILD_EXAMPLES=ON
}
package() {
- install -Dm644 "../../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-package_anki-drive-sdk-git() {
- pkgdesc="C SDK for message protocols and data parsing to communicate with Anki Drive vehicles"
- depends=('libankidrive')
- cd "$pkgbase/build/examples"
- make DESTDIR="${pkgdir}/usr" install
- package
-}
-package_libankidrive-git() {
- pkgdesc="C library of message protocols and data parsing to communicate with Anki Drive vehicles"
- depends=('glib2')
- conflicts=('libankidrive')
- replaces=('libankidrive')
- provides=('libankidrive')
cd "$pkgbase/build/src"
make DESTDIR="${pkgdir}/usr" install
+ cd "$pkgbase/build/examples"
+ make DESTDIR="${pkgdir}/usr" install
install -Dm644 '../../include/ankidrive.h' "${pkgdir}/usr/include/ankidrive.h"
install -dm755 "${pkgdir}/usr/include/ankidrive"
cp -a ../../include/ankidrive/*.h "${pkgdir}/usr/include/ankidrive/."
- package
+ install -Dm644 "../../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}