summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:50:49 +0200
committerSébastien Leduc2015-06-13 10:50:49 +0200
commit03fba8b94d5f9c7d82a7eeaa799a36f814ef06e2 (patch)
tree2a9dbfe882900f60c35166f55088760cc915df0f
downloadaur-03fba8b94d5f9c7d82a7eeaa799a36f814ef06e2.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--voximp.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0997b74526c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = voximp
+ pkgdesc = Control your desktop with your voice
+ pkgver = 0.0.1
+ pkgrel = 4
+ url = http://voximp.googlecode.com
+ install = voximp.install
+ arch = any
+ license = GPL
+ depends = gstreamer0.10-python
+ depends = gstreamer0.10-base-plugins
+ depends = python2
+ depends = pygtk
+ depends = pocketsphinx
+ depends = xdotool
+ source = http://voximp.googlecode.com/files/voximp-0.0.1.tar.gz
+ md5sums = 4e2b0d3a88257999866ad0028dd69c04
+
+pkgname = voximp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7de3fc748cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+# Contributor: Ben Duffield <jebavarde@gmail.com>
+
+pkgname=voximp
+pkgver=0.0.1
+pkgrel=4
+arch=("any")
+pkgdesc="Control your desktop with your voice"
+url="http://voximp.googlecode.com"
+license=("GPL")
+depends=("gstreamer0.10-python" "gstreamer0.10-base-plugins" "python2" "pygtk" "pocketsphinx" "xdotool")
+install=voximp.install
+source=("http://voximp.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+md5sums=("4e2b0d3a88257999866ad0028dd69c04")
+
+prepare() {
+ sed -i -e "s/python/python2/" "$srcdir/voximp.py"
+}
+
+package() {
+ install -D -m755 "$srcdir/voximp.py" "$pkgdir/usr/bin/voximp"
+ install -d -D -m755 "$srcdir/sample_configs" "$pkgdir/usr/share/voximp/sample_configs"
+ install -D -m644 "$srcdir"/sample_configs/* "$pkgdir/usr/share/voximp/sample_configs/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/voximp.install b/voximp.install
new file mode 100644
index 000000000000..434ff250bd0e
--- /dev/null
+++ b/voximp.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat << EOF
+==> Copy all the files in /usr/share/voximp/sample_configs to ~/.config/voximp
+==> Rename ~/.config/voximp/voximpconf.py.sample to ~/.config/voximp/voximpconf.py
+==> Edit the config file if you want, but remember, if you edit, you have to re-create language model.
+====> Insturctions for this can be found in the config file itself.
+==> Also, remember, the more commands you have, the less accurate it'll be.
+EOF
+
+}
+
+op=$1
+shift
+$op $*