summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2018-07-22 09:04:57 +0200
committerChristian Muehlhaeuser2018-07-22 09:04:57 +0200
commit040745bcc970bc87bf1650bcd2b5b847ea272571 (patch)
tree8859ba8e4cbddb3539cc61baa21549b31aea7426
downloadaur-040745bcc970bc87bf1650bcd2b5b847ea272571.tar.gz
Initial commit for package pam_beacon-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcfb20635744
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pam_beacon-git
+ pkgdesc = PAM module for multi-factor authentication with Bluetooth Devices & Beacons
+ pkgver = r19.0d4021f
+ pkgrel = 1
+ url = https://github.com/muesli/pam-beacon
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ makedepends = pam
+ depends = pam
+ provides = pam_beacon
+ source = git+https://github.com/muesli/pam-beacon.git
+ sha256sums = SKIP
+
+pkgname = pam_beacon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d39c88d88e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
+
+pkgname=pam_beacon-git
+pkgver=r19.0d4021f
+pkgrel=1
+pkgdesc="PAM module for multi-factor authentication with Bluetooth Devices & Beacons"
+arch=('x86_64')
+url="https://github.com/muesli/pam-beacon"
+license=('MIT')
+makedepends=('go' 'git' 'pam')
+depends=('pam')
+provides=('pam_beacon')
+source=('git+https://github.com/muesli/pam-beacon.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pam-beacon"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/pam-beacon"
+ GOPATH=`pwd` go get -d -v
+}
+
+build() {
+ cd "$srcdir/pam-beacon"
+ GOPATH=`pwd` make
+}
+
+package() {
+ cd "$srcdir/pam-beacon"
+
+ # Install binary
+ install -Dm755 "pam_beacon.so" "$pkgdir/usr/lib/security/pam_beacon.so"
+ # Copy License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}