aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdés2018-02-25 17:33:36 -0500
committerAlejandro Valdés2018-02-25 17:33:36 -0500
commit040f291a1df17f4b8c41c46fc50065b60a2b77b0 (patch)
tree11aeb78e1fe17ef3a3750a740f26ec191232f50e
downloadaur-040f291a1df17f4b8c41c46fc50065b60a2b77b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE.md23
-rw-r--r--PKGBUILD22
-rw-r--r--README.md6
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f829e892714
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mozart2-compiler
+ pkgdesc = An open source implementation of Oz 3.
+ pkgver = 2.0.0_alpha.0.4140
+ pkgrel = 1
+ url = https://mozart.github.io/
+ arch = x86_64
+ license = BSD
+ depends = tk
+ conflicts = mozart2
+ source = https://github.com/alevalv/mozart2-compiler-archlinux/releases/download/1.0/bin.rpm
+ source = https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt
+ sha512sums = dbdf8619d41918e7403a8ea3a7759fdc15013c9bece37ce10d16371428f15c66a31be3624175a4d49ce318647200eac56806922ba240935e421e061e32d8690c
+ sha512sums = c21dfa28faa03a703d853416126d2135330919036b33b40c790569bccb9a0fdbb3cd3acde0cd001a84333f7fe25a18d02be970612720d7726b01a26f0317a78b
+
+pkgname = mozart2-compiler
+
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..35ae536edae3
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,23 @@
+Copyright © 2011-2012, Université catholique de Louvain
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b2466660ed7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alejandro Valdes <alejandrovaldes@live.com>
+
+pkgname='mozart2-compiler'
+pkgver='2.0.0_alpha.0.4140'
+pkgrel=1
+pkgdesc='An open source implementation of Oz 3.'
+arch=('x86_64')
+url='https://mozart.github.io/'
+license=('BSD')
+depends=('tk')
+conflicts=('mozart2')
+source=(https://github.com/alevalv/mozart2-compiler-archlinux/releases/download/1.0/bin.rpm
+ https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt)
+sha512sums=('dbdf8619d41918e7403a8ea3a7759fdc15013c9bece37ce10d16371428f15c66a31be3624175a4d49ce318647200eac56806922ba240935e421e061e32d8690c'
+ 'c21dfa28faa03a703d853416126d2135330919036b33b40c790569bccb9a0fdbb3cd3acde0cd001a84333f7fe25a18d02be970612720d7726b01a26f0317a78b')
+package() {
+ cd "$srcdir"
+ rm usr/bin/oz
+ rm -r usr/share/applications
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ cp -R usr "$pkgdir"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..dcc1e3208c58
--- /dev/null
+++ b/README.md
@@ -0,0 +1,6 @@
+mozart2-compiler-archlinux
+===========================
+
+Repository with the PKGBUILD to create a barebones mozart2, it also includes the rpm as a release to easy download it.
+
+This package can be used as a companion to the [mozart vscode extension](https://marketplace.visualstudio.com/items?itemName=alevalv.oz-vscode) to avoid installing emacs.