summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-07-10 15:49:43 +0800
committerUniversebenzene2023-07-10 15:49:43 +0800
commit04117e6dba2fb6fff9deeff810fade9ac4c2f38d (patch)
treed0ac9592d4ddb7adeba1cc87ad5239cf78ed20db
parent5d6577ccf915e0343f85e50659d4266da8c9f254 (diff)
downloadaur-04117e6dba2fb6fff9deeff810fade9ac4c2f38d.tar.gz
Better check()
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49d6e24389bf..b067733df8c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,9 +37,9 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
- --deselect=build/lib.linux-x86_64-cpython-311/fast_histogram/tests/test_histogram.py::test_1d_compare_with_numpy \
- --deselect=build/lib.linux-x86_64-cpython-311/fast_histogram/tests/test_histogram.py::test_2d_compare_with_numpy \
- --deselect=build/lib.linux-x86_64-cpython-311/fast_histogram/tests/test_histogram.py::test_dd_compare_with_numpy || warning "Tests failed" -vv --color=yes
+ --deselect=build/lib.linux-x86_64-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_1d_compare_with_numpy \
+ --deselect=build/lib.linux-x86_64-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_2d_compare_with_numpy \
+ --deselect=build/lib.linux-x86_64-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_dd_compare_with_numpy || warning "Tests failed" # -vv --color=yes
}
package() {