summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2018-08-16 07:16:11 +0800
committerLin UX2018-08-16 07:16:11 +0800
commit041f94e0522c188ea3a56fb483bd2b5a22c30682 (patch)
treeb241ec1d8f396fe548146e5f42d1597d5e616026
parent802193d11afa724d1a59ae1c754744bbe0605774 (diff)
downloadaur-041f94e0522c188ea3a56fb483bd2b5a22c30682.tar.gz
correct optdeps
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD2
2 files changed, 10 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4de8bb2d6e8a..a7b094a8ea50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,17 @@ pkgbase = vim-python-mode
license = LGPL3
depends = vim
depends = python
+ optdepends = python-astroid
+ optdepends = autopep8
+ optdepends = python-mccabe
+ optdepends = python-pycodestyle
+ optdepends = python-pydocstyle
+ optdepends = python-pyflakes
+ optdepends = pylama
optdepends = python-pylint
optdepends = python-rope
+ optdepends = python-six
+ optdepends = python-snowballstemmer
source = https://github.com/python-mode/python-mode/archive/0.9.2.tar.gz
sha256sums = 1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd
diff --git a/PKGBUILD b/PKGBUILD
index c2d04fb123e5..d413065530fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('any')
license=('LGPL3')
url='https://github.com/python-mode/python-mode'
depends=('vim' 'python')
-optdepends=('python-pylint' 'python-rope')
+optdepends=('python-astroid' 'autopep8' 'python-mccabe' 'python-pycodestyle' 'python-pydocstyle' 'python-pyflakes' 'pylama' 'python-pylint' 'python-rope' 'python-six' 'python-snowballstemmer')
groups=('vim-plugins')
source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=(1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd)