summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmal Karunarathna2018-12-12 05:32:53 +0530
committerAmal Karunarathna2018-12-12 05:32:53 +0530
commit042aa2253046988a09ae9e4b740ff6bfb6325a99 (patch)
tree51f677047bcf523ff48b4737c2bfdc97db3f9445
downloadaur-042aa2253046988a09ae9e4b740ff6bfb6325a99.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84f293900a04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = captain-frank-cursors-git
+ pkgdesc = An x-cursor theme heavily based on capitaine cursors and elementary (Mint) for use on my KDE desktop.
+ pkgver = r18.78d8511
+ pkgrel = 1
+ url = https://github.com/ChrisP4/captain-frank-cursors
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = inkscape
+ conflicts = captain-frank-cursors
+ options = !strip
+ source = git+https://github.com/ChrisP4/captain-frank-cursors.git
+ sha256sums = SKIP
+
+pkgname = captain-frank-cursors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d02d612fd9ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+
+_gitname=captain-frank-cursors
+pkgname=captain-frank-cursors-git
+pkgver=r18.78d8511
+pkgrel=1
+pkgdesc="An x-cursor theme heavily based on capitaine cursors and elementary (Mint) for use on my KDE desktop."
+arch=('any')
+url="https://github.com/ChrisP4/${_gitname}"
+license=('GPL3')
+makedepends=(git inkscape)
+options=('!strip')
+conflicts=(${_gitname})
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_gitname
+ rm -rf ./dist
+ chmod +x ./build.sh
+ ./build.sh
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/icons/${_gitname}
+ cp -rf ${srcdir}/${_gitname}/dist/* ${pkgdir}/usr/share/icons/${_gitname}
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+ find ${pkgdir}/usr -type f -name '.directory' -delete
+}