summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAgustín DallʼAlba2022-03-19 22:00:52 +0000
committerAgustín DallʼAlba2022-03-19 22:04:19 +0000
commit043c54736b0170f583d9d7ae32def48afd0639c0 (patch)
tree614a2c9915ff34719662611c3a80d18cf6494e7c
parent6090f79424c9169c38b2435dc912341fee3736cb (diff)
downloadaur-043c54736b0170f583d9d7ae32def48afd0639c0.tar.gz
Fix that pkgver was 1.15 while upstream version was 1.8.4
- Modified `pkgver()` function to comply with the guidelines in the wiki. - Changed maintainer. - Added `provides` and `conflicts`. - Do not install licence file because it's already in common/GPL3.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e31c647bec..6dae7f28a11f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = astreamfs-git
pkgdesc = Fuse filesystem to read http(s) URL
- pkgver = 1.15.0
+ pkgver = 1.8.4
pkgrel = 1
+ epoch = 1
url = https://gitlab.com/BylonAkila/astreamfs
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
depends = fuse
+ provides = astreamfs
+ conflicts = astreamfs
source = git+https://gitlab.com/BylonAkila/astreamfs.git
sha1sums = SKIP
pkgname = astreamfs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 35164f0ae8e6..345b045389c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
-# Maintainer: Foxy <gmail: foxyblackhat@gmail.com>
+# Maintainer: Agustín DallʼAlba <aur@dallalba.com.ar>
+# Contributor: Foxy <foxyblackhat@gmail.com>
+
pkgname=astreamfs-git
-pkgver=1.15.0
+pkgver=1.8.4
pkgrel=1
+epoch=1
pkgdesc='Fuse filesystem to read http(s) URL'
-arch=(i686 x86_64)
+arch=('x86_64')
url='https://gitlab.com/BylonAkila/astreamfs'
-license=(GPL3)
+license=('GPL3')
depends=('fuse')
makedepends=('git')
-source=(git+https://gitlab.com/BylonAkila/astreamfs.git)
+provides=('astreamfs')
+conflicts=('astreamfs')
+source=('git+https://gitlab.com/BylonAkila/astreamfs.git')
sha1sums=('SKIP')
pkgver() {
cd astreamfs
- echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ git describe --long | sed 's/-/.r/;s/-/./'
}
build() {
@@ -25,5 +30,4 @@ package() {
cd astreamfs
install -Dm755 astreamfs "${pkgdir}/usr/bin/astreamfs"
install -Dm755 1fichier "${pkgdir}/usr/bin/1fichier"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}