summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2017-02-12 11:33:21 +0100
committerQuentin Bourgeois2017-02-12 11:33:21 +0100
commit0446203017765829d79badc4f4fa03f6d4161d3d (patch)
tree5e962499c1227a8d64c580d4d5dd061d97296713
downloadaur-0446203017765829d79badc4f4fa03f6d4161d3d.tar.gz
addpkg: chromium-app-mooltipass 2.0.61-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD30
-rw-r--r--cdifokahonpfaoldibbjmbkdhhelblpj.json4
5 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a091ded6934
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = chromium-app-mooltipass
+ pkgdesc = Mooltipass password manager client
+ pkgver = 2.0.61
+ pkgrel = 1
+ url = https://www.themooltipass.com/setup
+ arch = any
+ license = custom:MIT
+ depends = chromium
+ source = mooltipass-app.crx::https://clients2.google.com/service/update2/crx?response=redirect&prodversion=49.0&x=id%3Dcdifokahonpfaoldibbjmbkdhhelblpj%26installsource%3Dondemand%26uc
+ source = cdifokahonpfaoldibbjmbkdhhelblpj.json
+ source = LICENSE
+ sha256sums = 3ac647c3aa0dd549d3f731fbd6d955466967503f673a996b627f12ae9dcc5019
+ sha256sums = 5930a63d2f1b6a1357ebe728d3492aaec4ec1b38c4dc5d3761f0c09370a0741b
+ sha256sums = 2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866
+
+pkgname = chromium-app-mooltipass
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..345242887dda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+chromium-app-mooltipass-*
+mooltipass-app.crx
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..31ecdfb1dbc5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e58c69c528fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
+
+_app_name='mooltipass'
+_extension_id='cdifokahonpfaoldibbjmbkdhhelblpj'
+_store_base_url='https://clients2.google.com/service/update2/crx?response=redirect&prodversion=49.0&x=id%3D'
+pkgname="chromium-app-${_app_name}"
+pkgver=2.0.61
+pkgrel=1
+pkgdesc='Mooltipass password manager client'
+license=('custom:MIT')
+arch=('any')
+url='https://www.themooltipass.com/setup'
+depends=('chromium')
+source=("${_app_name}-app.crx::${_store_base_url}${_extension_id}%26installsource%3Dondemand%26uc"
+ "${_extension_id}.json"
+ 'LICENSE')
+sha256sums=('3ac647c3aa0dd549d3f731fbd6d955466967503f673a996b627f12ae9dcc5019'
+ '5930a63d2f1b6a1357ebe728d3492aaec4ec1b38c4dc5d3761f0c09370a0741b'
+ '2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 644 "${_app_name}-app.crx" \
+ "${pkgdir}/usr/lib/${CARCH}-linux-gnu/${_app_name}-app-chromium/${_app_name}-app.crx"
+ install -Dm 644 "${_extension_id}.json" \
+ "${pkgdir}/usr/share/chromium/extensions/${_extension_id}.json"
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/cdifokahonpfaoldibbjmbkdhhelblpj.json b/cdifokahonpfaoldibbjmbkdhhelblpj.json
new file mode 100644
index 000000000000..486a8a2aa660
--- /dev/null
+++ b/cdifokahonpfaoldibbjmbkdhhelblpj.json
@@ -0,0 +1,4 @@
+{
+ "external_crx": "/usr/lib/x86_64-linux-gnu/mooltipass-app-chromium/mooltipass-app.crx",
+ "external_version": "2.0.61"
+}