summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Szymański2021-04-25 17:12:02 +0200
committerJakub Szymański2021-04-25 17:12:02 +0200
commit0458fb389c1c6ee1ef7829e125fdc0bc33cf2a8f (patch)
tree51e425c71fc4ec263b5e784ac01d4d044aba7bba
parent5ab0217546a021e35368c191a2dfb79391114670 (diff)
downloadaur-0458fb389c1c6ee1ef7829e125fdc0bc33cf2a8f.tar.gz
Revert "Update to 0.2.8"
This reverts commit 5ab0217546a021e35368c191a2dfb79391114670. This version is possibly dangerous to use, see https://github.com/WoeUSB/WoeUSB-ng/issues/37
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--com.github.woeusb.woeusb-ng.policy28
3 files changed, 40 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3a310ca1951..a2ba2945d176 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = woeusb-ng
pkgdesc = Simple tool that enable you to create your own usb stick with Windows installer.
- pkgver = 0.2.8
- pkgrel = 1
+ pkgver = 0.2.7
+ pkgrel = 2
url = https://github.com/WoeUSB/WoeUSB-ng
arch = any
license = GPL3
@@ -19,8 +19,10 @@ pkgbase = woeusb-ng
provides = woeusb
conflicts = woeusb
conflicts = woeusb-git
- source = https://github.com/WoeUSB/WoeUSB-ng/archive/v0.2.8.tar.gz
- sha256sums = 8a7e0bd6ced96a02d7a3ad829073809a67d20e6099104ce0a9f5234699a07666
+ source = https://github.com/WoeUSB/WoeUSB-ng/archive/v0.2.7.tar.gz
+ source = com.github.woeusb.woeusb-ng.policy
+ sha256sums = 4546ca5cf703434602b9dac2724cbfe791bbbc21c9b72d01c655ff7b89d69672
+ sha256sums = 6700f9f324723447b9f5d69b940f3ae0b0dd8d1bfc65878f34990a8554482d06
pkgname = woeusb-ng
diff --git a/PKGBUILD b/PKGBUILD
index 9fb9da0fce8e..981536fe7143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jakub Szymański <jakubmateusz@poczta.onet.pl>
pkgname=woeusb-ng
-pkgver=0.2.8
-pkgrel=1
+pkgver=0.2.7
+pkgrel=2
pkgdesc="Simple tool that enable you to create your own usb stick with Windows installer."
arch=('any')
url="https://github.com/WoeUSB/WoeUSB-ng"
@@ -28,9 +28,11 @@ conflicts=(
)
source=(
"https://github.com/WoeUSB/WoeUSB-ng/archive/v$pkgver.tar.gz"
+ "com.github.woeusb.woeusb-ng.policy"
)
sha256sums=(
- "8a7e0bd6ced96a02d7a3ad829073809a67d20e6099104ce0a9f5234699a07666"
+ "4546ca5cf703434602b9dac2724cbfe791bbbc21c9b72d01c655ff7b89d69672"
+ "6700f9f324723447b9f5d69b940f3ae0b0dd8d1bfc65878f34990a8554482d06"
)
@@ -61,5 +63,5 @@ package() {
chmod 755 $pkgdir/usr/share/applications/WoeUSB-ng.desktop
# policy
- cp miscellaneous/com.github.woeusb.woeusb-ng.policy $pkgdir/usr/share/polkit-1/actions/com.github.woeusb.woeusb-ng.policy
+ cp ../com.github.woeusb.woeusb-ng.policy $pkgdir/usr/share/polkit-1/actions/com.github.woeusb.woeusb-ng.policy
}
diff --git a/com.github.woeusb.woeusb-ng.policy b/com.github.woeusb.woeusb-ng.policy
new file mode 100644
index 000000000000..65e4534190df
--- /dev/null
+++ b/com.github.woeusb.woeusb-ng.policy
@@ -0,0 +1,28 @@
+<?xml version="1.0" ?><!DOCTYPE policyconfig PUBLIC '-//freedesktop//DTD polkit Policy Configuration 1.0//EN' 'http://www.freedesktop.org/software/polkit/policyconfig-1.dtd'><!--
+DOC: https://www.freedesktop.org/software/polkit/docs/latest/polkit.8.html
+--><policyconfig>
+ <vendor>The WoeUSB Project</vendor>
+ <vendor_url>https://github.com/slacka/WoeUSB</vendor_url>
+ <icon_name>woeusbgui-icon</icon_name>
+
+ <action id="com.github.slacka.woeusb.run-gui-using-pkexec">
+ <description>Run `woeusb` as SuperUser</description>
+ <description xml:lang="zh_TW">以超級使用者(SuperUser)身份執行 `woeusb`</description>
+ <description xml:lang="pl_PL">Uruchom `woeusb` jako root</description>
+ <description xml:lang="pt_BR">Execute `woeusb` como root</description>
+
+ <message>Authentication is required to run `woeusb` as SuperUser.</message>
+ <message xml:lang="zh_TW">以超級使用者(SuperUser)身份執行 `woeusb` 需要通過身份驗證。</message>
+ <message xml:lang="pl_PL">Wymagana jest autoryzacja do uruchomienia `woeusb` jako root</message>
+ <message xml:lang="pt_BR">A autenticação é necessária para executar `woeusb` como root.</message>
+
+ <defaults>
+ <allow_any>auth_admin</allow_any>
+ <allow_inactive>auth_admin</allow_inactive>
+ <allow_active>auth_admin_keep</allow_active>
+ </defaults>
+
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/woeusbgui</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+</policyconfig>