summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-05-03 10:31:09 +0200
committera8212023-05-03 10:31:09 +0200
commit045b862ade772a775337ffe9a56d49adf718b9a4 (patch)
tree66eefd0d52abb5181065f42d46ce0da30425069d
parentac0040d848a351d1400c177cd28dd3fcb1535667 (diff)
downloadaur-045b862ade772a775337ffe9a56d49adf718b9a4.tar.gz
Version 0.5.10
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--asarray.patch22
3 files changed, 16 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 236c6b35dc2b..6955a8a9b481 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-pynndescent
pkgdesc = Simple fast approximate nearest neighbor search
- pkgver = 0.5.8
- pkgrel = 2
+ pkgver = 0.5.10
+ pkgrel = 1
url = https://github.com/lmcinnes/pynndescent
arch = any
license = BSD
checkdepends = python-pytest
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-joblib
depends = python-numba
depends = python-scikit-learn
depends = python-scipy
- source = https://pypi.io/packages/source/p/pynndescent/pynndescent-0.5.8.tar.gz
- source = asarray.patch
- sha256sums = a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b
- sha256sums = 240c9413befb3f7dd58a0f02a32e58a07c54abeef70cdaa222a3ec7bd8da7d63
+ source = https://pypi.io/packages/source/p/pynndescent/pynndescent-0.5.10.tar.gz
+ sha256sums = 5d5dc683c03ef55fe3ddf693859720ca18f85c6e6e5bb0b4f14870278d5288ad
pkgname = python-pynndescent
diff --git a/PKGBUILD b/PKGBUILD
index 83f65584feae..7cfec99ef468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: a821
pkgname=python-pynndescent
-pkgver=0.5.8
-pkgrel=2
+pkgver=0.5.10
+pkgrel=1
pkgdesc="Simple fast approximate nearest neighbor search"
arch=('any')
url="https://github.com/lmcinnes/pynndescent"
license=('BSD')
depends=('python-joblib' 'python-numba' 'python-scikit-learn' 'python-scipy')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest')
-source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz"
- "asarray.patch")
-sha256sums=('a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b'
- '240c9413befb3f7dd58a0f02a32e58a07c54abeef70cdaa222a3ec7bd8da7d63')
+source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz")
+sha256sums=('5d5dc683c03ef55fe3ddf693859720ca18f85c6e6e5bb0b4f14870278d5288ad')
-prepare() {
+build() {
cd "pynndescent-$pkgver"
- patch -p1 < ../asarray.patch
+ python -m build --wheel --no-isolation
}
check() {
@@ -25,7 +23,7 @@ check() {
}
package() {
- cd "$srcdir/pynndescent-$pkgver"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "pynndescent-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/asarray.patch b/asarray.patch
deleted file mode 100644
index 9ba097b106f2..000000000000
--- a/asarray.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/pynndescent/tests/test_distances.py b/pynndescent/tests/test_distances.py
-index 101530b..9ad88b0 100644
---- a/pynndescent/tests/test_distances.py
-+++ b/pynndescent/tests/test_distances.py
-@@ -109,7 +109,7 @@ def test_binary_check(binary_data, metric):
- def test_sparse_spatial_check(sparse_spatial_data, metric, decimal=6):
- if metric in spdist.sparse_named_distances:
- dist_matrix = pairwise_distances(
-- sparse_spatial_data.todense().astype(np.float32), metric=metric
-+ np.asarray(sparse_spatial_data.todense().astype(np.float32)), metric=metric
- )
- if metric in ("braycurtis", "dice", "sokalsneath", "yule"):
- dist_matrix[np.where(~np.isfinite(dist_matrix))] = 0.0
-@@ -174,7 +174,7 @@ def test_sparse_spatial_check(sparse_spatial_data, metric, decimal=6):
- )
- def test_sparse_binary_check(sparse_binary_data, metric):
- if metric in spdist.sparse_named_distances:
-- dist_matrix = pairwise_distances(sparse_binary_data.todense(), metric=metric)
-+ dist_matrix = pairwise_distances(np.asarray(sparse_binary_data.todense()), metric=metric)
- if metric in ("jaccard", "dice", "sokalsneath"):
- dist_matrix[np.where(~np.isfinite(dist_matrix))] = 0.0
- if metric in ("kulsinski", "russellrao"):