summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 17:59:42 +0200
committerMaxime Gauduin2017-05-01 17:59:42 +0200
commit0475f6b2f0acdd17a7a4a1efc5dfbdc129793c65 (patch)
tree94733189cb687a2653025e1a40ab2ae9487d1819
downloadaur-0475f6b2f0acdd17a7a4a1efc5dfbdc129793c65.tar.gz
Add wingpanel-indicator-notifications-git
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD51
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fca14e3673cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon May 1 15:59:42 UTC 2017
+pkgbase = wingpanel-indicator-notifications-git
+ pkgdesc = Notifications indicator for Wingpanel
+ pkgver = r223.92ffe1a
+ pkgrel = 1
+ url = https://github.com/elementary/wingpanel-indicator-notifications
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = vala
+ makedepends = wingpanel-git
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libwnck3
+ depends = libgranite.so
+ depends = libwingpanel-2.0.so
+ provides = wingpanel-indicator-notifications
+ conflicts = wingpanel-indicator-notifications
+ source = git+https://github.com/elementary/wingpanel-indicator-notifications.git
+ sha256sums = SKIP
+
+pkgname = wingpanel-indicator-notifications-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0360aab374f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-notifications-git
+pkgver=r223.92ffe1a
+pkgrel=1
+pkgdesc='Notifications indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/wingpanel-indicator-notifications'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'libgee' 'libwnck3'
+ 'libgranite.so' 'libwingpanel-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'vala' 'wingpanel-git')
+provides=('wingpanel-indicator-notifications')
+conflicts=('wingpanel-indicator-notifications')
+source=('git+https://github.com/elementary/wingpanel-indicator-notifications.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel-indicator-notifications
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd wingpanel-indicator-notifications
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-notifications/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='OFF'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-notifications/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: