summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-11-02 18:41:54 +0100
committerfrederik2017-11-02 18:41:54 +0100
commit048ad895bf7f451d3fcea502834d1333a351dd74 (patch)
tree0a35163a574e101004ffe97ee37f563af54f5fe4
downloadaur-048ad895bf7f451d3fcea502834d1333a351dd74.tar.gz
initial commit from gogland
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--jetbrains-goland.desktop10
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3b94e4167c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Nov 2 17:41:35 UTC 2017
+pkgbase = goland
+ pkgdesc = Capable and Ergonomic Go IDE
+ pkgver = 173.3415.23
+ pkgrel = 1
+ url = https://www.jetbrains.com/go/
+ arch = x86_64
+ arch = i686
+ license = Commercial
+ makedepends = rsync
+ options = !strip
+ source = https://download.jetbrains.com/go/goland-173.3415.23.tar.gz
+ source = jetbrains-goland.desktop
+ sha512sums = 7cfcf07bef5115cecff9913551ec4af8cd493a341e30cb818223b5c36345c5816bba118f53f5ad652dc78533b336530ca98dba9f34e81a322c94a332d49f4524
+ sha512sums = 49d0ecaa2082c4325107b0ce6b1eeda2c6983a779c45d3a44be0888f4321797db8613dd8b724b43695bf6884c3150e505d44d1aa74cd6efed49ed0879181ef36
+
+pkgname = goland
+ optdepends = goland-jre: JetBrains custom Java Runtime (Recommended)
+ optdepends = java-runtime>=8: JRE - Required if goland-jre is not installed
+
+pkgname = goland-jre
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc26bbbb17d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+
+pkgbase=goland
+pkgname=(goland goland-jre)
+pkgver=173.3415.23
+pkgrel=1
+pkgdesc='Capable and Ergonomic Go IDE'
+arch=('x86_64' 'i686')
+url='https://www.jetbrains.com/go/'
+license=('Commercial')
+makedepends=('rsync')
+options=('!strip')
+source=(https://download.jetbrains.com/go/${pkgbase}-${pkgver}.tar.gz
+ jetbrains-goland.desktop)
+sha512sums=('7cfcf07bef5115cecff9913551ec4af8cd493a341e30cb818223b5c36345c5816bba118f53f5ad652dc78533b336530ca98dba9f34e81a322c94a332d49f4524'
+ '49d0ecaa2082c4325107b0ce6b1eeda2c6983a779c45d3a44be0888f4321797db8613dd8b724b43695bf6884c3150e505d44d1aa74cd6efed49ed0879181ef36')
+
+package_goland() {
+ optdepends=('goland-jre: JetBrains custom Java Runtime (Recommended)'
+ 'java-runtime>=8: JRE - Required if goland-jre is not installed')
+
+ install -d -m 755 "${pkgdir}/opt/"
+ install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/usr/share/applications/"
+ install -d -m 755 "${pkgdir}/usr/share/pixmaps/"
+
+ rsync -rtl "${srcdir}/Gogland-${pkgver}/" "${pkgdir}/opt/${pkgbase}" --exclude=/jre64
+
+ chmod +x "${pkgdir}/opt/${pkgbase}/plugins/intellij-go-plugin/lib/dlv/linux/dlv"
+ ln -s "/opt/${pkgbase}/bin/${pkgbase}.sh" "${pkgdir}/usr/bin/${pkgbase}"
+ install -D -m 644 "${srcdir}/jetbrains-${pkgbase}.desktop" "${pkgdir}/usr/share/applications/"
+ install -D -m 644 "${pkgdir}/opt/${pkgbase}/bin/${pkgbase}.png" "${pkgdir}/usr/share/pixmaps/${pkgbase}.png"
+}
+
+package_goland-jre() {
+ install -d -m 755 "${pkgdir}/opt/${pkgbase}"
+ rsync -rtl "${srcdir}/Gogland-${pkgver}/jre64" "${pkgdir}/opt/${pkgbase}"
+}
diff --git a/jetbrains-goland.desktop b/jetbrains-goland.desktop
new file mode 100644
index 000000000000..00e77d06bb1d
--- /dev/null
+++ b/jetbrains-goland.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=GoLand
+Icon=/opt/goland/bin/goland.png
+Exec="/opt/goland/bin/goland.sh" %f
+Comment=The Drive to Develop
+Categories=Development;IDE;
+Terminal=false
+StartupWMClass=jetbrains-goland