summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-09-01 17:24:04 -0700
committerJesus Alvarez2017-09-01 17:24:04 -0700
commit048f8aa30f2f64c54077874d81ed53bfd6a32cd7 (patch)
treeeee05e97ef7da2ac2d0b1aa14fbb94b1813e6ddc
parent329491ce5cde508467a01e93664116840f6131d2 (diff)
downloadaur-048f8aa30f2f64c54077874d81ed53bfd6a32cd7.tar.gz
Semi-automated update for 4.12.8.2-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--zfs.install2
3 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a0f4e48c3df..90e49ea13580 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Aug 2 05:24:56 UTC 2017
+# Sat Sep 2 00:22:02 UTC 2017
pkgbase = zfs-archiso-linux
- pkgver = 0.7.0_4.12.3_1
+ pkgver = 0.7.1_4.12.8.2
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.12.3
+ makedepends = linux-headers=4.12.8
makedepends = spl-archiso-linux-headers
depends = kmod
depends = spl-archiso-linux
- depends = zfs-utils-common>=0.7.0
- depends = linux=4.12.3
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz
- sha256sums = 6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2
+ depends = zfs-utils-common>=0.7.1
+ depends = linux=4.12.8
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz
+ sha256sums = 231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6
pkgname = zfs-archiso-linux
pkgdesc = Kernel modules for the Zettabyte File System.
@@ -30,4 +30,6 @@ pkgname = zfs-archiso-linux-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-zen-headers
+ conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 23e08e271e28..d1327cfa054d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
#
pkgbase="zfs-archiso-linux"
pkgname=("zfs-archiso-linux" "zfs-archiso-linux-headers")
-pkgver=0.7.0_4.12.3_1
+pkgver=0.7.1_4.12.8.2
pkgrel=1
-makedepends=("linux-headers=4.12.3" "spl-archiso-linux-headers")
+makedepends=("linux-headers=4.12.8" "spl-archiso-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz")
-sha256sums=("6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz")
+sha256sums=("231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6")
license=("CDDL")
-depends=("kmod" "spl-archiso-linux" "zfs-utils-common>=0.7.0" "linux=4.12.3")
+depends=("kmod" "spl-archiso-linux" "zfs-utils-common>=0.7.1" "linux=4.12.8")
build() {
- cd "${srcdir}/zfs-0.7.0"
+ cd "${srcdir}/zfs-0.7.1"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.12.3-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.8-2-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.12.8-2-ARCH/build
make
}
@@ -44,7 +44,7 @@ package_zfs-archiso-linux() {
provides=("zfs")
groups=("archzfs-archiso-linux")
conflicts=()
- cd "${srcdir}/zfs-0.7.0"
+ cd "${srcdir}/zfs-0.7.1"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -54,10 +54,10 @@ package_zfs-archiso-linux() {
package_zfs-archiso-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=( 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
- cd "${srcdir}/zfs-0.7.0"
+ conflicts=( 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ cd "${srcdir}/zfs-0.7.1"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.8-2-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 7e1ba1655196..b3a768cc87c7 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.12.3-1-ARCH
+ depmod -a 4.12.8-2-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'