summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantman6662023-06-22 17:45:53 +0800
committerantman6662023-06-22 17:45:53 +0800
commit04b72f967d52415999dd8bc7f7f199b7da31cebc (patch)
tree08272c08ad28bf2673c9987e5ccfe0c1f83f651b
parentcb411e40e6fed1c8902cf0444e88aabf08112ca7 (diff)
downloadaur-04b72f967d52415999dd8bc7f7f199b7da31cebc.tar.gz
update linux-xanmod-tt-uksm-cjktty to 6.3.9-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xchoose-gcc-optimization.sh11
3 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb3d8d951bd9..d55218b267e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,7 +29,7 @@ pkgbase = linux-xanmod-tt-uksm-cjktty
sha256sums = ba3491f5ed6bd270a370c440434e3d69085fcdd528922fa01e73d7657db73b1e
sha256sums = SKIP
sha256sums = 4fa4c79654e32e45a211c549954ecd7352dc46a42e7b9239f16ed442c8fe9dc7
- sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
+ sha256sums = 5c84bfe7c1971354cff3f6b3f52bf33e7bbeec22f85d5e7bfde383b54c679d30
sha256sums = 427b16aeece1b62667ab34d45e43e4f476f5f4875daf8553597c95e2bfa22ef1
sha256sums = eb7d7f0b0c7bca67140cc02109f022f06637b8fed1229d4f37a2d7af5bd38dde
diff --git a/PKGBUILD b/PKGBUILD
index e14d6fcf2285..c7200f6ebb17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -146,7 +146,7 @@ done
sha256sums=('ba3491f5ed6bd270a370c440434e3d69085fcdd528922fa01e73d7657db73b1e'
'SKIP'
'4fa4c79654e32e45a211c549954ecd7352dc46a42e7b9239f16ed442c8fe9dc7'
- '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
+ '5c84bfe7c1971354cff3f6b3f52bf33e7bbeec22f85d5e7bfde383b54c679d30'
'427b16aeece1b62667ab34d45e43e4f476f5f4875daf8553597c95e2bfa22ef1'
'eb7d7f0b0c7bca67140cc02109f022f06637b8fed1229d4f37a2d7af5bd38dde')
diff --git a/choose-gcc-optimization.sh b/choose-gcc-optimization.sh
index f10eec54b81d..fe05516c66c6 100755
--- a/choose-gcc-optimization.sh
+++ b/choose-gcc-optimization.sh
@@ -66,7 +66,7 @@ cat << EOF
98) Intel-Native optimizations autodetected by GCC
99) AMD-Native optimizations autodetected by GCC
- 0) Generic (default)
+ 0) Generic x64-v1 (default)
EOF
@@ -133,7 +133,16 @@ warning "According to PKGBUILD variable _microarchitecture, your choice is $answ
msg "Building this package for microarchitecture: $Microarchitecture$default"
sleep 5
+_defaultmicro=$(grep ^CONFIG_LOCALVERSION .config)
+if [ -z "${default}" ]; then
+ _localversion=$(echo ${Microarchitecture,,} | sed -e 's/config_m/-/g' -e 's/config_generic_cpu/-x64v/g')
+ sed -e "s|^$_defaultmicro|CONFIG_LOCALVERSION=\"$_localversion\"|g" -i .config
+fi
+
sed -e 's|^CONFIG_GENERIC_CPU=y|# CONFIG_GENERIC_CPU is not set|g' -i .config
+sed -e 's|^CONFIG_GENERIC_CPU2=y|# CONFIG_GENERIC_CPU2 is not set|g' -i .config
+sed -e 's|^CONFIG_GENERIC_CPU3=y|# CONFIG_GENERIC_CPU3 is not set|g' -i .config
+sed -e 's|^CONFIG_GENERIC_CPU4=y|# CONFIG_GENERIC_CPU4 is not set|g' -i .config
sed -e "s|^# $Microarchitecture is not set|$Microarchitecture=y|g" -i .config
echo