summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-08-18 01:07:32 -0400
committerChris Severance2020-08-18 01:07:32 -0400
commit04bf2545cb14e7de901d9975b179ed6476325b0a (patch)
treebc9601d20efc65682ad33814e6633d71868e635e
parent774668701ec25a1d9b41ff1f6b7f83b5898212d0 (diff)
downloadaur-04bf2545cb14e7de901d9975b179ed6476325b0a.tar.gz
Update to 1.17.44
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 769b633771f3..533b26d86a34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Apr 23 19:36:03 UTC 2020
+# Tue Aug 18 05:07:32 UTC 2020
pkgbase = python-botocore-git
pkgdesc = A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3
- pkgver = 1.15.45.r6694.g6c73c753d
+ pkgver = 1.17.44.r7044.g5986ae80c
pkgrel = 1
url = https://github.com/boto/botocore
arch = any
@@ -25,7 +25,7 @@ pkgbase = python-botocore-git
depends = python-sphinx>=1.1.3
depends = python-guzzle-sphinx-theme>=0.7.10
depends = python-six>=1.1.0
- provides = python-botocore=1.15.45
+ provides = python-botocore=1.17.44
conflicts = python-botocore
options = !strip
source = botocore::git+https://github.com/boto/botocore.git
diff --git a/PKGBUILD b/PKGBUILD
index 8bd76659d3be..97f427f21738 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,13 +26,11 @@ behave==1.2.5
jsonschema==2.5.1
#setup.py
-[metadata]
-requires-dist =
- python-dateutil>=2.1,<3.0.0
- jmespath>=0.7.1,<1.0.0
- docutils>=0.10,<0.16
- urllib3>=1.20,<1.25.8; python_version=='3.4'
- urllib3>=1.20,<1.26; python_version!='3.4'
+requires = [
+ 'jmespath>=0.7.1,<1.0.0',
+ 'docutils>=0.10,<0.16',
+ 'python-dateutil>=2.1,<3.0.0',
+]
if sys.version_info[:2] == (3, 4):
@@ -48,7 +46,7 @@ set -u
_pyver="python"
_pybase='botocore'
pkgname="${_pyver}-${_pybase}-git"
-pkgver=1.15.45.r6694.g6c73c753d
+pkgver=1.17.44.r7044.g5986ae80c
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
@@ -82,7 +80,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('3b7dc218a8535918b53784beb0d36e231444e6f20475f50e262662bb38523cc8')
+sha256sums=('07e902e82963b98af99606fc58f2d04dfec5b2768209477ac1642c4ee1550574')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"