summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuflosi2022-12-13 17:36:26 +0100
committerLuflosi2022-12-13 17:36:26 +0100
commit04c10c18aa36057dd0ad386fcafb30468e073088 (patch)
tree0b6841fe999fe7d0bdd048f6928c1d3fc60e57bb
parent9e7058424065ed64de5471a29ac0a1dab3d041f1 (diff)
downloadaur-04c10c18aa36057dd0ad386fcafb30468e073088.tar.gz
Fix build
Follow the advice in https://wiki.archlinux.org/title/VCS_package_guidelines#Git_submodules to disable a new security feature in git, which prevents file:// clones by default.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fc624f39b4a..2738f5960e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Adam Harvey <adam@adamharvey.name>
pkgname=apfs-fuse-git
-pkgver=r77.670e45e
+pkgver=r93.04f3246
pkgrel=1
pkgdesc="FUSE driver for APFS (Apple File System)"
arch=('i686' 'x86_64')
@@ -26,7 +26,7 @@ prepare() {
cd "${pkgname%-git}"
git submodule init
git config submodule.3rdparty/lzfse.url "$srcdir/lzfse"
- git submodule update
+ git -c protocol.file.allow=always submodule update
mkdir -p build
}