summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2016-08-12 22:55:16 -0700
committerMike Swanson2016-08-12 22:55:16 -0700
commit04dc8075abbdceadbf7fef7a42baee3c864ecdc3 (patch)
treebdca2708176f43bf9317b4a1b694edb977e06d1e
downloadaur-04dc8075abbdceadbf7fef7a42baee3c864ecdc3.tar.gz
HSXKPasswd 3.6
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67efd004c501
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Aug 13 05:55:01 UTC 2016
+pkgbase = hsxkpasswd
+ pkgdesc = Generate secure, memorable passwords inspired by XKCD and Password Haystacks
+ pkgver = 3.6
+ pkgrel = 1
+ url = https://www.bartbusschots.ie/s/publications/software/xkpasswd/
+ arch = any
+ license = BSD
+ makedepends = perl-module-build
+ depends = perl
+ depends = perl-clone
+ depends = perl-datetime
+ depends = perl-file-homedir
+ depends = perl-file-share
+ depends = perl-json
+ depends = perl-list-moreutils
+ depends = perl-math-round
+ depends = perl-readonly
+ depends = perl-text-unidecode
+ depends = perl-type-tiny
+ source = https://github.com/bbusschots/hsxkpasswd/archive/v3.6.tar.gz
+ sha256sums = 3dd7b6332bbd1bbb6435c669d83592c94d7c5537a3fb9b6efaf9a3c09f3cd86d
+
+pkgname = hsxkpasswd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbe009640b4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8e01acad928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=hsxkpasswd
+pkgver=3.6
+pkgrel=1
+pkgdesc="Generate secure, memorable passwords inspired by XKCD and Password Haystacks"
+arch=('any')
+url="https://www.bartbusschots.ie/s/publications/software/xkpasswd/"
+license=('BSD')
+depends=('perl' 'perl-clone' 'perl-datetime' 'perl-file-homedir'
+ 'perl-file-share' 'perl-json' 'perl-list-moreutils' 'perl-math-round'
+ 'perl-readonly' 'perl-text-unidecode' 'perl-type-tiny')
+makedepends=('perl-module-build')
+source=("https://github.com/bbusschots/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('3dd7b6332bbd1bbb6435c669d83592c94d7c5537a3fb9b6efaf9a3c09f3cd86d')
+
+build() {
+ cd "$pkgname-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ perl ./Build.PL
+ ./Build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}