summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYorick Peterse2023-05-19 18:21:23 +0200
committerYorick Peterse2023-05-19 18:21:23 +0200
commit04e8e3f85ccc68d95042a21d01b8265e21cf7428 (patch)
treedaf62966d049a05b1a7580bdb9c5872db123ae33
parentb86172c201e8caea49efe9ac5d14dd7ba96f8cca (diff)
downloadaur-04e8e3f85ccc68d95042a21d01b8265e21cf7428.tar.gz
Update for version 0.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85c007731642..d49606d4ee9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = inko-git
pkgdesc = A language for building concurrent software with confidence
- pkgver = 0.10.0.r2.gcfc2dce6
+ pkgver = 0.11.0.r1.g72160419
pkgrel = 1
url = https://inko-lang.org
arch = x86_64
license = MPL2
- makedepends = rust>=1.62
+ makedepends = rust>=1.63
makedepends = make
- depends = libffi>=3.2.0
+ depends = llvm>=15.0.0
+ depends = llvm<=16.0.0
+ depends = git
+ depends = base-devel
provides = inko
conflicts = inko
- conflicts = inko-bin
options = strip
options = !docs
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index ecf5b2951b36..bb3efc5f188a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Yorick Peterse <aur AT yorickpeterse DOT com>
pkgname=inko-git
-pkgver=0.10.0.r2.gcfc2dce6
+pkgver=0.11.0.r1.g72160419
pkgrel=1
-pkgdesc="A language for building concurrent software with confidence"
+pkgdesc="A language for building concurrent software with confidence "
url="https://inko-lang.org"
license=(MPL2)
arch=(x86_64)
-depends=('libffi>=3.2.0')
-makedepends=('rust>=1.62' make)
+depends=('llvm>=15.0.0' 'llvm<=16.0.0' git base-devel)
+makedepends=('rust>=1.63' make)
provides=(inko)
-conflicts=(inko inko-bin)
+conflicts=(inko)
options=(strip !docs !libtool !staticlibs)
source=('inko::git+https://github.com/inko-lang/inko.git')
sha256sums=('SKIP')
@@ -22,10 +22,7 @@ pkgver() {
build() {
cd inko
-
- # Enable the libffi-system feature so the system libffy is used, instead of
- # compiling it from source.
- make build FEATURES='libffi-system' PREFIX='/usr'
+ make build PREFIX='/usr'
}
package() {