summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-10-13 15:40:52 +0200
committerTérence Clastres2019-10-13 15:44:01 +0200
commit04eaf8cec41200a51fd1ec86ebef27990d7e4e13 (patch)
treed364de6511c93aafb537c5236a98b7b519ffdd37
parentc7831b6040630d256106775b8169eda5a3666983 (diff)
downloadaur-04eaf8cec41200a51fd1ec86ebef27990d7e4e13.tar.gz
Remove previous patch, remove '--disable-headers'
libglvnd provides the original problematic pkgconfig files but this commit: https://gitlab.freedesktop.org/mesa/mesa/commit/34ba363ab0e231c2842c4a045dc51c5b1cd33401 removes important headers from mesa. Current workaround is to make libglvnd provides them.
-rw-r--r--.SRCINFO11
-rw-r--r--Add-pkgconfig-data-for-libraries-implemented-so-far.patch152
-rw-r--r--PKGBUILD19
3 files changed, 15 insertions, 167 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a36e3e299c74..6b3cb6df9dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libglvnd-glesv2
pkgdesc = The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1
- pkgver = 1.1.1
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://github.com/NVIDIA/libglvnd
arch = x86_64
license = custom:BSD-like
@@ -15,11 +15,10 @@ pkgbase = libglvnd-glesv2
provides = libegl
provides = libgles
conflicts = libglvnd
- source = libglvnd-glesv2-1.1.1.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v1.1.1.tar.gz
- source = Add-pkgconfig-data-for-libraries-implemented-so-far.patch
+ source = libglvnd-glesv2-1.2.0.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v1.2.0.tar.gz
source = LICENSE
- sha512sums = f64a481be002b108bc45147f9ecddc97561d09b15dd2fee82e76642f8d298f5b21458042dea3083ade650181d5f937bf550bba2914fbf46a774990abdbc56883
- sha512sums = ff685ebc716c13d169202fb8ada979c7f5121e3106897886777e8b54ea5fc35358389412bfcc398a4304463108676c3ed295f905ea8c2dedd3d9145ac2b505af
+ sha512sums = 0e0e9c3f303739c73f5bee4c2aaef9eff56440345f2f1ce285ee98eb94c1e5e740774dd501aeeed1299aa25a449d813a850e95282999a3ca4648d2381d6c8fa6
+ sha512sums = 368b3392d17169efdc3d85b26b418026c4a42aa1ce95779fe763adb96e750e17e61c99f97e99831068e55a126f3279adda9bf70025783e61d7aaa60d37dbe808
sha512sums = bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5
pkgname = libglvnd-glesv2
diff --git a/Add-pkgconfig-data-for-libraries-implemented-so-far.patch b/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
deleted file mode 100644
index 32397560bc43..000000000000
--- a/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index cdbb138..be8fc4e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -324,11 +324,16 @@ AC_CONFIG_FILES([Makefile
- include/Makefile
- src/Makefile
- src/GL/Makefile
-+ src/OpenGL/opengl.pc
- src/OpenGL/Makefile
-+ src/GLESv1/glesv1_cm.pc
- src/GLESv1/Makefile
-+ src/GLESv2/glesv2.pc
- src/GLESv2/Makefile
-+ src/GLX/glx.pc
- src/GLX/Makefile
- src/EGL/Makefile
-+ src/EGL/egl.pc
- src/GLdispatch/Makefile
- src/GLdispatch/vnd-glapi/Makefile
- src/util/Makefile
-diff --git a/src/EGL/Makefile.am b/src/EGL/Makefile.am
-index 5c036dc..c55c83e 100644
---- a/src/EGL/Makefile.am
-+++ b/src/EGL/Makefile.am
-@@ -106,3 +106,6 @@ g_egldispatchstubs.c : $(GENERATE_DEPS)
- g_egldispatchstubs.h : $(GENERATE_DEPS)
- $(AM_V_GEN)$(PYTHON) $(GENERATE_DISPATCH_SCRIPT) header $(GENERATE_LIST_FILES) > $@
- endif
-+
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = egl.pc
-diff --git a/src/EGL/egl.pc.in b/src/EGL/egl.pc.in
-new file mode 100644
-index 0000000..6ed6933
---- /dev/null
-+++ b/src/EGL/egl.pc.in
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=${prefix}
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: egl
-+Description: Mesa EGL Library
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lEGL
-+Cflags: -I${includedir}
-diff --git a/src/GLESv1/Makefile.am b/src/GLESv1/Makefile.am
-index d20017d..88e07bc 100644
---- a/src/GLESv1/Makefile.am
-+++ b/src/GLESv1/Makefile.am
-@@ -38,3 +38,5 @@ libGLESv1_CM_la_LIBADD = \
- ../GLdispatch/vnd-glapi/libglapi_glesv1.la \
- ../util/libutils_misc.la
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = glesv1_cm.pc
-diff --git a/src/GLESv1/glesv1_cm.pc.in b/src/GLESv1/glesv1_cm.pc.in
-new file mode 100644
-index 0000000..c0473e8
---- /dev/null
-+++ b/src/GLESv1/glesv1_cm.pc.in
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=${prefix}
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: glesv1_cm
-+Description: OpenGL ES-CM v1 library and headers
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lGLESv1_CM
-+Cflags: -I${includedir}
-diff --git a/src/GLESv2/Makefile.am b/src/GLESv2/Makefile.am
-index a9c2351..f40e06f 100644
---- a/src/GLESv2/Makefile.am
-+++ b/src/GLESv2/Makefile.am
-@@ -38,3 +38,5 @@ libGLESv2_la_LIBADD = \
- ../GLdispatch/vnd-glapi/libglapi_glesv2.la \
- ../util/libutils_misc.la
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = glesv2.pc
-diff --git a/src/GLESv2/glesv2.pc.in b/src/GLESv2/glesv2.pc.in
-new file mode 100644
-index 0000000..d72b5ba
---- /dev/null
-+++ b/src/GLESv2/glesv2.pc.in
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=${prefix}
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: gles2
-+Description: OpenGL ES v2/v3 library and headers
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lGLESv2
-+Cflags: -I${includedir}
-diff --git a/src/GLX/Makefile.am b/src/GLX/Makefile.am
-index 030836b..0d19674 100644
---- a/src/GLX/Makefile.am
-+++ b/src/GLX/Makefile.am
-@@ -69,3 +69,5 @@ libGLX_la_SOURCES = \
- libglxmapping.c \
- libglxproto.c
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = glx.pc
-diff --git a/src/GLX/glx.pc.in b/src/GLX/glx.pc.in
-new file mode 100644
-index 0000000..733d4cb
---- /dev/null
-+++ b/src/GLX/glx.pc.in
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=${prefix}
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: glx
-+Description: GLX library and headers
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lGLX
-+Cflags: -I${includedir}
-diff --git a/src/OpenGL/Makefile.am b/src/OpenGL/Makefile.am
-index 647d9e4..4b34dd5 100644
---- a/src/OpenGL/Makefile.am
-+++ b/src/OpenGL/Makefile.am
-@@ -47,3 +47,5 @@ libOpenGL_la_LIBADD = \
- ../GLdispatch/vnd-glapi/libglapi_opengl.la \
- ../util/libutils_misc.la
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = opengl.pc
-diff --git a/src/OpenGL/opengl.pc.in b/src/OpenGL/opengl.pc.in
-new file mode 100644
-index 0000000..3eb2903
---- /dev/null
-+++ b/src/OpenGL/opengl.pc.in
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=${prefix}
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: opengl
-+Description: OpenGL (without GLX) headers and interface
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lOpenGL
-+Cflags: -I${includedir}
diff --git a/PKGBUILD b/PKGBUILD
index 0bb1cfa78e61..413de9e57163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=libglvnd-glesv2
_pkgname=${pkgname/-glesv2}
-pkgver=1.1.1
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1"
arch=('x86_64')
url="https://github.com/NVIDIA/libglvnd"
@@ -14,20 +14,17 @@ makedepends=('libxext' 'libx11' 'glproto' 'python')
provides=('libglvnd' 'libgl' 'libegl' 'libgles')
conflicts=('libglvnd')
source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$pkgver.tar.gz"
- Add-pkgconfig-data-for-libraries-implemented-so-far.patch
LICENSE)
-sha512sums=('f64a481be002b108bc45147f9ecddc97561d09b15dd2fee82e76642f8d298f5b21458042dea3083ade650181d5f937bf550bba2914fbf46a774990abdbc56883'
- 'ff685ebc716c13d169202fb8ada979c7f5121e3106897886777e8b54ea5fc35358389412bfcc398a4304463108676c3ed295f905ea8c2dedd3d9145ac2b505af'
+sha512sums=('0e0e9c3f303739c73f5bee4c2aaef9eff56440345f2f1ce285ee98eb94c1e5e740774dd501aeeed1299aa25a449d813a850e95282999a3ca4648d2381d6c8fa6'
+ '368b3392d17169efdc3d85b26b418026c4a42aa1ce95779fe763adb96e750e17e61c99f97e99831068e55a126f3279adda9bf70025783e61d7aaa60d37dbe808'
'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
build() {
cd $_pkgname-$pkgver
- # https://bugs.freedesktop.org/show_bug.cgi?id=110141
- patch -Np1 < "$srcdir"/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
-
./autogen.sh
- ./configure --prefix=/usr
+ ./configure --prefix=/usr \
+ # --disable-headers
make
}
@@ -39,4 +36,8 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # FS#64044
+ rm "$pkgdir"/usr/lib/pkgconfig/glesv1*
+ rm "$pkgdir"/usr/lib/libGLESv1*
}