summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViech2021-05-15 15:01:53 +0200
committerViech2021-05-15 15:01:53 +0200
commit04ec7020bff39fd641f3cc1d147a936b7d4abcb7 (patch)
tree69994169b968415b38573e28e45db902ed0da54b
parent5cb749995924a0d5485bd4b422e0ad6db169b62a (diff)
downloadaur-04ec7020bff39fd641f3cc1d147a936b7d4abcb7.tar.gz
Update to 0.52.0.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD48
2 files changed, 18 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd297319e87..9c758414e86c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = unvanquished-data
pkgdesc = Game assets for Unvanquished.
- pkgver = 0.51.2
+ pkgver = 0.52.0
pkgrel = 1
- url = http://www.unvanquished.net
+ url = https://www.unvanquished.net
arch = any
license = GPL3
makedepends = aria2>=1.18.7-2
- source = https://github.com/Unvanquished/Unvanquished/raw/archlinux/0.51.2-1/download-dpk-torrent.sh
- md5sums = a53bcb79af17ca7b7050a62bd023f814
+ source = https://raw.githubusercontent.com/Unvanquished/Unvanquished/v0.52.0/download-paks
+ md5sums = 6b0bce3c6cefac4c92a922afc9e47a11
pkgname = unvanquished-data
diff --git a/PKGBUILD b/PKGBUILD
index a37601cba20b..3ba4cf183894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,31 @@
# Maintainer: Viech <viech unvanquished net>
+# NOTE: For 0.52.0 only, we do not copy old assets from the system because:
+# 1. The new script does not allow seeding the download like this yet.
+# 2. A full redownload is necessary for this release anyway.
+
pkgname=unvanquished-data
-pkgver=0.51.2
+pkgver=0.52.0
pkgrel=1
-
-_gitver="archlinux/${pkgver}-${pkgrel}"
-
pkgdesc='Game assets for Unvanquished.'
arch=('any')
-url='http://www.unvanquished.net'
+url='https://www.unvanquished.net'
license=('GPL3')
-
makedepends=('aria2>=1.18.7-2')
-source=("https://github.com/Unvanquished/Unvanquished/raw/${_gitver}/download-dpk-torrent.sh")
+source=("https://raw.githubusercontent.com/Unvanquished/Unvanquished/v${pkgver}/download-paks")
+md5sums=('6b0bce3c6cefac4c92a922afc9e47a11')
-# disable package compression since assets are already compressed
+# Disable package compression since assets are already compressed.
PKGEXT='.pkg.tar'
-build() {
- cd "${srcdir}"
-
- chmod +x download-dpk-torrent.sh
+prepare() {
+ chmod +x "${srcdir}/download-paks"
}
package() {
- # create installation directory
+ # Create installation directory.
install -dm755 "${pkgdir}/usr/share/unvanquished/pkg/"
- # use package source directory as the cache for the download script
- if [ ! -d "${srcdir}/cache" ]; then
- mkdir "${srcdir}/cache"
- fi
-
- # attempt to copy existing assets from the system, so they aren't redownloaded
- if [ -d /usr/share/unvanquished/pkg ]; then
- echo "Copying existing assets from the system..."
- cp -r /usr/share/unvanquished/pkg/*.dpk "${pkgdir}/usr/share/unvanquished/pkg/" || true
- fi
-
- # make the download script aware of copied assets, so it will remove unneeded ones
- ls -c1 "${pkgdir}/usr/share/unvanquished/pkg/" > "${srcdir}/cache/last-assets.txt"
-
- # remove old aria2 progress files in case the torrent itself was updated
- rm -f "${srcdir}/cache/"*".aria2"
-
- # download new or modified assets
- ./download-dpk-torrent.sh "${pkgdir}/usr/share/unvanquished/pkg/" "${srcdir}/cache" "${pkgver}"
+ # Download assets.
+ ./download-paks "${pkgdir}/usr/share/unvanquished/pkg/" "${srcdir}"
}
-
-md5sums=('a53bcb79af17ca7b7050a62bd023f814')