summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2013-06-07 20:37:55 +0000
committerThomas Weißschuh2013-06-07 20:37:55 +0000
commit04f0cc0c433eb09edde50d10e34290031b8e130e (patch)
treea2fb586d053c3bf505b21202743197e23c956e77
downloadaur-04f0cc0c433eb09edde50d10e34290031b8e130e.tar.gz
add hdapsd-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd21b9690b86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hdapsd-git
+ pkgdesc = HDAPS userspace hard drive protection daemon
+ pkgver = 20130420
+ pkgrel = 1
+ url = https://github.com/evgeni/hdapsd/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ provides = hdapsd
+ conflicts = hdapsd
+ source = git+https://github.com/evgeni/hdapsd/
+ sha256sums = SKIP
+
+pkgname = hdapsd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..046beba8d139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname=hdapsd-git
+pkgver=20130420
+pkgrel=1
+pkgdesc='HDAPS userspace hard drive protection daemon'
+arch=('i686' 'x86_64')
+url='https://github.com/evgeni/hdapsd/'
+license=('GPL')
+depends=('glibc')
+provides=('hdapsd')
+conflicts=('hdapsd')
+source=('git+https://github.com/evgeni/hdapsd/')
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/hdapsd/"
+
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${srcdir}/hdapsd/"
+
+ make DESTDIR="${pkgdir}/" install
+
+ mv "$pkgdir"/usr/lib/udev/rules.d/{,80-}hdapsd.rules
+}
+
+pkgver() {
+ date '+%Y%m%d'
+}