summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2023-11-02 19:23:38 +0800
committerChih-Hsuan Yen2023-11-02 19:23:38 +0800
commit050e992aea0d1e93c13199bac90a0106713ff028 (patch)
tree5f539071abb10eb9c517aebddafe012aeab4411e
parent9582ce28dec143e64d9cd1c769a21121f4a3671f (diff)
downloadaur-050e992aea0d1e93c13199bac90a0106713ff028.tar.gz
Fix building
* Switch to the new git repo URL * Add python-pytest-pacman following [1] * Add python-pkgconfig following [2] * Backport a patch to fix tests [3] [1] https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/4 [2] https://gitlab.archlinux.org/archlinux/pyalpm/-/commit/ad6186997a6f278f7679e5ed8af91716fc3dbe88 [3] https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/19
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c5a90dd338d..aad9e1a6eb2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.8.4.r100.gbca42ad
+ pkgver = 0.10.6.r9.g90941d0
pkgrel = 1
url = https://git.archlinux.org/pyalpm.git/
arch = x86_64
license = GPL3
checkdepends = python-pytest
+ checkdepends = python-pytest-pacman
makedepends = git
makedepends = python-setuptools
+ makedepends = python-pkgconfig
depends = python>=3.6
depends = pacman>=5
- provides = pyalpm=0.8.4.r100.gbca42ad
+ provides = pyalpm=0.10.6.r9.g90941d0
conflicts = pyalpm
- source = git+https://git.archlinux.org/pyalpm.git
+ source = git+https://gitlab.archlinux.org/archlinux/pyalpm.git
+ source = pyalpm-mr19.patch::https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/19.patch
sha256sums = SKIP
+ sha256sums = 78098e9ebdc2e90846cb836913edab0ca74abdf5c8e846468063300a017d5fb7
pkgname = pyalpm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 03c918a4571c..43074b0af8e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.4.r100.gbca42ad
+pkgver=0.10.6.r9.g90941d0
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('x86_64')
url="https://git.archlinux.org/pyalpm.git/"
license=('GPL3')
depends=('python>=3.6' 'pacman>=5')
-makedepends=('git' 'python-setuptools')
-checkdepends=('python-pytest')
+makedepends=('git' 'python-setuptools' 'python-pkgconfig')
+checkdepends=('python-pytest' 'python-pytest-pacman')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=('git+https://git.archlinux.org/pyalpm.git')
-sha256sums=('SKIP')
+source=('git+https://gitlab.archlinux.org/archlinux/pyalpm.git'
+ 'pyalpm-mr19.patch::https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/19.patch')
+sha256sums=('SKIP'
+ '78098e9ebdc2e90846cb836913edab0ca74abdf5c8e846468063300a017d5fb7')
pkgver() {
cd $_pkgname
@@ -28,8 +30,7 @@ pkgver() {
prepare() {
cd $_pkgname
- # https://github.com/archlinux/pyalpm/pull/31
- sed -i 's#str(excinfo)#str(excinfo.value)#' test/*.py
+ patch -Np1 -i ../pyalpm-mr19.patch
}
build() {