summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2017-06-21 20:54:27 -0400
committerbrent s2017-06-21 20:54:27 -0400
commit05222b9388299d77af225068548ba113d4728ae0 (patch)
treed654f2be23ca8da802193ce7da6ce3311e9788bc
parentc08db84c3b6c4f986afdd50cb86344975a22e084 (diff)
downloadaur-05222b9388299d77af225068548ba113d4728ae0.tar.gz
updating to 1.6.17
-rw-r--r--PKGBUILD44
-rw-r--r--freeswitch-arch.patch37
-rw-r--r--freeswitch-arch.patch.sigbin0 -> 566 bytes
3 files changed, 64 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa51eab29024..72caa41b47f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,7 @@ _disabled_modules=(languages/mod_spidermonkey
# BUILD CONFIGURATION ENDS #
pkgname='freeswitch'
-pkgver='1.6.15'
+pkgver='1.6.17'
pkgrel=1
pkgdesc="An opensource and free (libre, price) telephony system, similar to Asterisk."
arch=('i686' 'x86_64')
@@ -68,10 +68,11 @@ depends=('curl'
'speex'
'libjpeg-turbo'
'postgresql-libs'
- 'libshout'
- 'lua'
- 'opus'
- 'freetype2')
+ 'libshout'
+ 'lua'
+ 'openssl-1.0'
+ 'opus'
+ 'freetype2')
# per https://wiki.freeswitch.org/wiki/FreeSwitch_Dependencies, dependencies are downloaded and built *from upstream*, so thankfully the deps are pretty minimal.
makedepends=('git'
'libjpeg'
@@ -82,11 +83,11 @@ makedepends=('git'
'unixodbc'
'sed'
'make'
- 'libyuv-git'
- 'yasm'
- 'mpg123'
- 'lame'
- 'libsndfile')
+ 'libyuv-git'
+ 'yasm'
+ 'mpg123'
+ 'lame'
+ 'libsndfile')
# per https://aur.archlinux.org/packages/freeswitch-fixed/ 2014-08-13 14:02 comment, enable this when freetdm is packaged.
# freetdm will require libsangoma, wanpipe, libsng_isdn, libpri. see http://wiki.freeswitch.org/wiki/FreeTDM#Dependencies ; links below
# http://wiki.sangoma.com/wanpipe-linux-drivers
@@ -106,12 +107,14 @@ source=("git+https://stash.freeswitch.org/scm/fs/freeswitch.git#tag=v${pkgver}"
'run_log.freeswitch'
'conf_log.freeswitch'
'freeswitch.service'
- 'freeswitch.conf.d.sig'
- 'README.freeswitch.sig'
- 'run.freeswitch.sig'
- 'run_log.freeswitch.sig'
- 'conf_log.freeswitch.sig'
- 'freeswitch.service.sig')
+ 'freeswitch-arch.patch' # required for 1.6.17
+ 'freeswitch.conf.d.sig'
+ 'README.freeswitch.sig'
+ 'run.freeswitch.sig'
+ 'run_log.freeswitch.sig'
+ 'conf_log.freeswitch.sig'
+ 'freeswitch.service.sig'
+ 'freeswitch-arch.patch.sig') # required for 1.6.17
changelog='ChangeLog'
_pkgname="freeswitch"
sha512sums=('SKIP'
@@ -121,6 +124,8 @@ sha512sums=('SKIP'
'e0ad57847905d11540567512fb224587a96db086ecaefd949964bd7e5bf29e448497fb3d6df5d88dbedd69beb5ae4618bb0e8462cbbb9fad84947c6932fc0b46'
'a4fd539de109de3475abfeb2bd8a95670af3f5af83bd6f6b229df19e81da3f121c28a62cff282f9dc152908ebe0f24f76743e00c72fa04dc1fd465a00dc6f976'
'0d71a056de156f5840effabf6fb37a20e64ae011ecd48bf049886d4c073fe251cd6adeb0380784622b570948e1ca30ce7c92a2cade230a7177c97ed697e6f1cb'
+ '4d4f5237297b298010b8a0b264435cc2c04742ca313272e7558f164b19aef97afaace5cf005eeffcfa6be096daedace67931cc209bccdabd2f3d01a42b643036'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -164,7 +169,10 @@ build() {
sleep 5
# CONFIGURE
- ./configure \
+ # We need to override some things for the ./configure for 1.6.17
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+ CFLAGS+=" -I/usr/include/openssl-1.0"
+ LDFLAGS+=" -I/usr/lib/openssl-1.0" ./configure \
--prefix=/var/lib/freeswitch \
--with-python=/usr/bin/python2 \
--bindir=/usr/bin \
@@ -185,6 +193,8 @@ build() {
--with-certsdir=/etc/freeswitch/certs \
--with-rundir=/run/freeswitch
+ patch -Np1 < ../freeswitch-arch.patch # needed for 1.6.17
+
# COMPILE
make
diff --git a/freeswitch-arch.patch b/freeswitch-arch.patch
new file mode 100644
index 000000000000..c72da4f7f467
--- /dev/null
+++ b/freeswitch-arch.patch
@@ -0,0 +1,37 @@
+# Thanks, mal! [https://aur.archlinux.org/account/mal]
+diff -ura freeswitch-orig/src/switch_ivr_play_say.c freeswitch/src/switch_ivr_play_say.c
+--- freeswitch-orig/src/switch_ivr_play_say.c 2017-06-16 02:59:16.014037406 -0400
++++ freeswitch/src/switch_ivr_play_say.c 2017-06-16 03:05:49.060484516 -0400
+@@ -1665,7 +1665,7 @@
+ }
+ }
+
+- buflen = FILE_STARTSAMPLES * sizeof(*abuf) * fh->cur_channels ? fh->cur_channels : fh->channels;
++ buflen = FILE_STARTSAMPLES * sizeof(*abuf) * (fh->cur_channels ? fh->cur_channels : fh->channels);
+
+ if (buflen > write_frame.buflen) {
+ abuf = realloc(abuf, buflen);
+diff -ura freeswitch-orig/libs/esl/fs_cli.c freeswitch/libs/esl/fs_cli.c
+--- freeswitch-orig/libs/esl/fs_cli.c 2017-06-21 12:52:54.490320046 -0400
++++ freeswitch/libs/esl/fs_cli.c 2017-06-21 12:49:53.456699573 -0400
+@@ -76,7 +76,7 @@
+ static int warn_stop = 0;
+ static int connected = 0;
+ static int allow_ctl_c = 0;
+-static char bare_prompt_str[512] = "";
++static char bare_prompt_str[514] = "";
+ static int bare_prompt_str_len = 0;
+ static char prompt_str[512] = "";
+ static char prompt_color[12] = {ESL_SEQ_DEFAULT_COLOR};
+diff -ura freeswitch-orig/libs/sofia-sip/libsofia-sip-ua/msg/msg_parser.c freeswitch/libs/sofia-sip/libsofia-sip-ua/msg/msg_parser.c
+--- freeswitch-orig/libs/sofia-sip/libsofia-sip-ua/msg/msg_parser.c 2017-06-21 15:55:33.568293668 -0400
++++ freeswitch/libs/sofia-sip/libsofia-sip-ua/msg/msg_parser.c 2017-06-21 15:56:42.057160786 -0400
+@@ -2017,7 +2017,7 @@
+ for (last = h; last->sh_succ; last = last->sh_succ) {
+ /* Ensure that chain is connected */
+ assert(last->sh_next == last->sh_succ);
+- assert(last->sh_succ->sh_prev = &last->sh_succ);
++ assert(last->sh_succ->sh_prev == &last->sh_succ);
+ }
+ prev = &last->sh_succ;
+ }
diff --git a/freeswitch-arch.patch.sig b/freeswitch-arch.patch.sig
new file mode 100644
index 000000000000..ad013921b5b0
--- /dev/null
+++ b/freeswitch-arch.patch.sig
Binary files differ