summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-07-20 18:02:04 +0200
committerPhilipp A2020-07-20 18:02:04 +0200
commit0531929c0171432dada36cb1ce0cfacb06b4d657 (patch)
treecab30bc5dbfa5eca2a49beb0e3d134b67d090c34
downloadaur-0531929c0171432dada36cb1ce0cfacb06b4d657.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0025d0d372e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-tiledb
+ pkgdesc = Pythonic interface to the TileDB array storage manager
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = https://github.com/TileDB-Inc/TileDB-Py
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ depends = python
+ depends = python-setuptools
+ depends = python-numpy>=1.16
+ noextract = tiledb-0.6.5-cp38-cp38-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp38/t/tiledb/tiledb-0.6.5-cp38-cp38-manylinux1_x86_64.whl
+ sha256sums = d8fea3df7543e8704954921c1cd5da1a8f495e38b2e5f28c58550931857a17d6
+
+pkgname = python-tiledb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..910c2436b01b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.*
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b4afda9dc35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=tiledb
+pkgname=python-$_name
+pkgver=0.6.5
+pkgrel=1
+pkgdesc='Pythonic interface to the TileDB array storage manager'
+arch=(x86_64)
+url="https://github.com/TileDB-Inc/TileDB-Py"
+license=(MIT)
+depends=(python python-setuptools 'python-numpy>=1.16')
+makedepends=(unzip)
+_wheel="${_name/-/_}-$pkgver-cp38-cp38-manylinux1_$CARCH.whl"
+source=("https://files.pythonhosted.org/packages/cp38/${_name::1}/$_name/$_wheel")
+sha256sums=('d8fea3df7543e8704954921c1cd5da1a8f495e38b2e5f28c58550931857a17d6')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}