summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2021-06-10 15:22:06 -0400
committerbrent s2021-06-10 15:22:06 -0400
commit055c987e433b9d037f7906f8c569bdd6d552a77d (patch)
tree4d83c52c6d75241bba13c5e6c7484d8699121ee8
parent5b0195ceebf138b95fb51ea8c511f7a7d68bc61e (diff)
downloadaur-055c987e433b9d037f7906f8c569bdd6d552a77d.tar.gz
fixing for upstream changing filename for initramfs
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD19
-rw-r--r--initramfs.patch12
-rw-r--r--initramfs.patch.sigbin0 -> 566 bytes
4 files changed, 39 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18a121fceb88..e6accb1f49c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = pixiecore-git
pkgdesc = An all-in-one tool for easy netbooting
- pkgver = r306.870d490
+ pkgver = r349.bdaec9d
pkgrel = 1
- url = https://github.com/google/netboot
- arch = x86_64
- arch = armv7h
- license = GPL2
- makedepends = git
+ url = https://godoc.org/go.universe.tf/netboot/pixiecore
+ arch = any
+ license = Apache
makedepends = go
- depends = glibc
+ makedepends = gcc
+ makedepends = binutils
provides = pixiecore
conflicts = pixiecore
+ source = pixiecore::git+https://github.com/danderson/netboot.git#branch=master
+ source = initramfs.patch
+ source = initramfs.patch.sig
+ validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
+ sha512sums = SKIP
+ sha512sums = 6deb1f06a213cfe252c989e895d9370b3310c5308cb5de3b13c1441cfc83bbe7832717538e916563f18c550c4c79115da16e635746fa33cd9248b79939e6e483
+ sha512sums = SKIP
pkgname = pixiecore-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cb066b169ec7..7981b22d11fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,23 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=pixiecore-git
_pkgname='pixiecore'
-pkgver=r328.72fa512
+pkgver=r349.bdaec9d
pkgrel=1
pkgdesc="An all-in-one tool for easy netbooting"
arch=('any')
url="https://godoc.org/go.universe.tf/netboot/pixiecore"
license=('Apache')
makedepends=('go'
-'gcc'
-'binutils')
+ 'gcc'
+ 'binutils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}") # pending removal from AUR; upstream has no static versioning
-source=("${_pkgname}::git+https://github.com/danderson/netboot.git#branch=master")
-sha512sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/danderson/netboot.git#branch=master"
+ "initramfs.patch"
+ "initramfs.patch.sig")
+sha512sums=('SKIP'
+ '6deb1f06a213cfe252c989e895d9370b3310c5308cb5de3b13c1441cfc83bbe7832717538e916563f18c550c4c79115da16e635746fa33cd9248b79939e6e483'
+ 'SKIP')
pkgver(){
cd "${srcdir}/${_pkgname}"
@@ -24,6 +28,11 @@ pkgver(){
}
# https://wiki.archlinux.org/index.php/Go_package_guidelines
+
+prepare(){
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 < "${srcdir}/initramfs.patch"
+}
build(){
cd "${srcdir}/${_pkgname}"
diff --git a/initramfs.patch b/initramfs.patch
new file mode 100644
index 000000000000..7b29116f2eaa
--- /dev/null
+++ b/initramfs.patch
@@ -0,0 +1,12 @@
+--- a/pixiecore/cli/quickcmd.go 2021-06-10 14:31:38.184997500 -0400
++++ b/pixiecore/cli/quickcmd.go 2021-06-10 15:15:25.489444234 -0400
+@@ -331,7 +331,7 @@
+
+ httpSrv := fmt.Sprintf("%s/iso/%s", mirror, version)
+ kernel := fmt.Sprintf("%s/arch/boot/%s/vmlinuz-linux", httpSrv, arch)
+- initrd := fmt.Sprintf("%s/arch/boot/%s/archiso.img", httpSrv, arch)
++ initrd := fmt.Sprintf("%s/arch/boot/%s/initramfs-linux.img", httpSrv, arch)
+ cmdline := fmt.Sprintf("archisobasedir=arch archiso_http_srv=%s/ ip=dhcp verify=y net.ifnames=0", httpSrv)
+
+ fmt.Println(staticFromFlags(cmd, kernel, []string{initrd}, cmdline).Serve())
+
diff --git a/initramfs.patch.sig b/initramfs.patch.sig
new file mode 100644
index 000000000000..235ae8cde2e5
--- /dev/null
+++ b/initramfs.patch.sig
Binary files differ