summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaekyung Kim2019-07-12 06:29:45 +0900
committerTaekyung Kim2019-07-12 06:29:45 +0900
commit055d571ee55967f8d9ac689ed1be8d76fba177d6 (patch)
treeb6b0497ce276c9b7829129f4ace14f893807e9c8
parentd4dfd999abcd3372a639ca3ec78832b3a154060c (diff)
downloadaur-055d571ee55967f8d9ac689ed1be8d76fba177d6.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f362d5d7502..7c5311c7ebe6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = r-rcppeigen
pkgdesc = Rcpp Integration for the Eigen Templated Linear Algebra Library
- pkgver = 0.3.3.4.0
+ pkgver = 0.3.3.5.0
pkgrel = 1
url = https://cran.r-project.org/package=RcppEigen
arch = x86_64
- license = GPL
+ license = GPL2
+ license = GPL3
license = custom
- depends = r
+ depends = r>=2.15.1
depends = r-rcpp>=0.11.0
optdepends = r-inline
optdepends = r-runit
optdepends = r-pkgkitten
- source = https://cran.r-project.org/src/contrib/RcppEigen_0.3.3.4.0.tar.gz
- md5sums = 78ee1ef7c6043efa875434ae5fcea2ec
+ optdepends = r-microbenchmark
+ source = https://cran.r-project.org/src/contrib/RcppEigen_0.3.3.5.0.tar.gz
+ md5sums = 9ec372cea453794167b0b2773387714f
pkgname = r-rcppeigen
diff --git a/PKGBUILD b/PKGBUILD
index d046b31211c3..3d5eb8ad52e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
+# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
+# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=RcppEigen
-_cranver=0.3.3.4.0
+_cranver=0.3.3.5.0
_pkgtar=${_cranname}_${_cranver}.tar.gz
pkgname=r-rcppeigen
pkgver=${_cranver//[:-]/.}
@@ -8,19 +10,16 @@ pkgrel=1
pkgdesc="Rcpp Integration for the Eigen Templated Linear Algebra Library"
arch=('x86_64')
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL' 'custom')
-depends=('r' 'r-rcpp>=0.11.0')
-
-optdepends=('r-inline' 'r-runit' 'r-pkgkitten')
-
+license=('GPL2' 'GPL3' 'custom')
+depends=('r>=2.15.1' 'r-rcpp>=0.11.0')
+optdepends=('r-inline' 'r-runit' 'r-pkgkitten' 'r-microbenchmark')
source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('78ee1ef7c6043efa875434ae5fcea2ec')
+md5sums=('9ec372cea453794167b0b2773387714f')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL "${_pkgtar}" -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
}
-