aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-11-11 07:30:40 -0500
committerSolomon Choina2020-11-11 07:30:40 -0500
commit0579f31bbaf6bcf29be445bcfb0414789bf32c49 (patch)
tree188aa32bad3c229d20f3e9413c59ee4b13fb5ee7
parentcfdf2253c135d2e99675bc3c12e1ca836dad6952 (diff)
downloadaur-0579f31bbaf6bcf29be445bcfb0414789bf32c49.tar.gz
updating openbox, new patches and shit
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e93481cfa43..11a81f40f861 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openbox-debian
pkgdesc = Openbox with Patches from Debian.
pkgver = 3.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://openbox.org
arch = i686
arch = x86_64
@@ -9,6 +9,8 @@ pkgbase = openbox-debian
groups = lxde-gtk3
groups = lxqt
license = GPL
+ makedepends = automake-1.11
+ makedepends = docbook-to-man
depends = startup-notification
depends = libxml2
depends = libxinerama
@@ -20,7 +22,7 @@ pkgbase = openbox-debian
depends = libsm
optdepends = gnome-panel: for the openbox gnome session
optdepends = plasma-workspace: for the KDE/Openbox xsession
- optdepends = python2-xdg: for the openbox-xdg-autostart script
+ optdepends = python-xdg: for the openbox-xdg-autostart script
provides = libobrender.so
provides = openbox
provides = openbox
@@ -30,9 +32,9 @@ pkgbase = openbox-debian
backup = etc/xdg/openbox/autostart
backup = etc/xdg/openbox/environment
source = http://openbox.org/dist/openbox/openbox-3.6.1.tar.gz
- source = http://http.debian.net/debian/pool/main/o/openbox/openbox_3.6.1-7.debian.tar.xz
+ source = http://http.debian.net/debian/pool/main/o/openbox/openbox_3.6.1-9.debian.tar.xz
md5sums = b72794996c6a3ad94634727b95f9d204
- md5sums = a809b1630d1d9b84dc9d58d127eab6b5
+ md5sums = c3d0b24f7a5cd615b1d951cb0031c60c
pkgname = openbox-debian
diff --git a/PKGBUILD b/PKGBUILD
index ffe24d995496..9766b495e0d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=openbox-debian
_pkgname=openbox
pkgver=3.6.1
-pkgrel=1
+pkgrel=2
pkgdesc='Openbox with Patches from Debian.'
arch=('i686' 'x86_64')
url='http://openbox.org'
@@ -23,21 +23,23 @@ depends=('startup-notification' 'libxml2' 'libxinerama' 'libxrandr'
'libxcursor' 'pango' 'imlib2' 'librsvg' 'libsm')
optdepends=('gnome-panel: for the openbox gnome session '
'plasma-workspace: for the KDE/Openbox xsession'
- 'python2-xdg: for the openbox-xdg-autostart script')
+ 'python-xdg: for the openbox-xdg-autostart script')
+makedepends=('automake-1.11' 'docbook-to-man')
groups=('lxde' 'lxde-gtk3' 'lxqt')
backup=('etc/xdg/openbox/menu.xml'
'etc/xdg/openbox/rc.xml'
'etc/xdg/openbox/autostart'
'etc/xdg/openbox/environment')
source=("http://openbox.org/dist/openbox/${_pkgname}-${pkgver}.tar.gz"
- "http://http.debian.net/debian/pool/main/o/openbox/openbox_3.6.1-7.debian.tar.xz")
+ "http://http.debian.net/debian/pool/main/o/openbox/openbox_3.6.1-9.debian.tar.xz")
md5sums=('b72794996c6a3ad94634727b95f9d204'
- 'a809b1630d1d9b84dc9d58d127eab6b5')
+ 'c3d0b24f7a5cd615b1d951cb0031c60c')
prepare() {
cd "${_pkgname}-${pkgver}"
local patches=(
+ 01_rc.xml.patch
02_fix_freedesktop_compliance.patch
04_fix_xml_load_file.patch
05_openbox-3.5.0-title-matching.patch
@@ -46,21 +48,22 @@ prepare() {
08_autostart-fix.patch
704724_fix_refers-to-autostart.sh.patch
719620_fix_show_startup_notification.patch
+ 754207_use-scrot.patch
808138_Replace-getgrent-with-getgroups.patch
d9a405e9.patch
fix-spelling-error-in-binary.patch
- adapt-to-gsd-324.patch
- 843231.patch
- 09-disable-check-gnome-version.patch
- 887908.patch
+ adapt-to-gsd-324.patch
+ 843231.patch
+ 09-disable-check-gnome-version.patch
+ 887908.patch
+ 917204_undecorated_maximized_no_border.patch
+ python3.patch
)
for i in "${patches[@]}"; do
msg "Applying ${i} ..."
patch -p1 -i "../debian/patches/${i}"
done
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|' \
- data/autostart/openbox-xdg-autostart
}
build() {