summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-06-22 21:42:41 -0400
committerVincent Grande2020-06-22 21:42:41 -0400
commit05965b73c858a71cc5ca50d0bd1221d51d6f2924 (patch)
tree27a6f8408de4c8ae015239355d78b29aebc8530c
downloadaur-05965b73c858a71cc5ca50d0bd1221d51d6f2924.tar.gz
initial upload
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD56
-rw-r--r--gtk2.install17
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f6f64967fa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = lib32-gtk2-git
+ pkgdesc = GObject-based multi-platform GUI toolkit (legacy) (32-bit)
+ pkgver = 2.24.32+62+g56c6970b02
+ pkgrel = 1
+ url = https://www.gtk.org/
+ install = gtk2.install
+ arch = x86_64
+ license = LGPL
+ makedepends = python
+ depends = lib32-atk>=1.30.0
+ depends = lib32-pango>=1.28.0
+ depends = lib32-cairo>=1.10.0
+ depends = lib32-gdk-pixbuf2>=2.22.1
+ depends = lib32-libcups>=1.4.4
+ depends = lib32-libxcursor
+ depends = lib32-libxrandr>=1.3
+ depends = lib32-libxi>=1.3
+ depends = lib32-libxinerama
+ depends = lib32-libxcomposite
+ depends = lib32-libxdamage
+ depends = gtk2
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git
+ sha256sums = SKIP
+
+pkgname = lib32-gtk2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..703960cbf998
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
+
+_pkgbasename=gtk2
+pkgname=lib32-$_pkgbasename-git
+pkgver=2.24.32+62+g56c6970b02
+pkgrel=1
+pkgdesc="GObject-based multi-platform GUI toolkit (legacy) (32-bit)"
+arch=('x86_64')
+url="https://www.gtk.org/"
+install=gtk2.install
+depends=(lib32-{'atk>=1.30.0','pango>=1.28.0','cairo>=1.10.0','gdk-pixbuf2>=2.22.1'}
+ lib32-lib{'cups>=1.4.4',xcursor,'xrandr>=1.3','xi>=1.3',xinerama,xcomposite,xdamage}
+ $_pkgbasename)
+makedepends=('python')
+license=('LGPL')
+source=(git+https://gitlab.gnome.org/GNOME/gtk.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd gtk
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib32 \
+ --with-xinput=yes \
+ --disable-gtk-doc
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd gtk
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/etc
+ rm -rf "${pkgdir}"/usr/{include,share}
+
+ cd "${pkgdir}"/usr/bin
+ mv gtk-query-immodules-2.0 gtk-query-immodules-2.0-32
+ rm -f gtk-builder-convert gtk-demo gtk-update-icon-cache
+}
diff --git a/gtk2.install b/gtk2.install
new file mode 100644
index 000000000000..6315484831dc
--- /dev/null
+++ b/gtk2.install
@@ -0,0 +1,17 @@
+post_install() {
+ GTK_PATH=/usr/lib32/gtk-2.0 usr/bin/gtk-query-immodules-2.0-32 --update-cache
+}
+
+pre_upgrade() {
+if (( $(vercmp $2 2.24.20) < 0 )); then
+ rm -f /etc/gtk-2.0/gtk.immodules-32
+fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm -f /usr/lib32/gtk-2.0/2.10.0/immodules.cache
+}