summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-09-12 22:44:06 -0400
committerBen Wolsieffer2016-09-12 22:44:06 -0400
commit059899573fec44a8d3969f911a0d04dc23b9cc8f (patch)
treed177d86068776b11968cd81ea237fb011b6cc33f
parentb12c3c98319ac23c3ace44d7a656f9d6a737bd08 (diff)
downloadaur-059899573fec44a8d3969f911a0d04dc23b9cc8f.tar.gz
Fix dependencies and update URLs.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e6eb9564f1a..be9bffc07b13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 15:41:01 UTC 2016
+# Tue Sep 13 02:44:03 UTC 2016
pkgbase = qdriverstation-git
- pkgdesc = Drive your FRC robot with your phone or tablet!
- pkgver = r778.1601ab1
+ pkgdesc = Open source clone of the FRC Driver Station
+ pkgver = r1054.9393cc2
pkgrel = 1
- url = https://github.com/wint-3794/qdriverstation
+ url = https://github.com/FRC-Utilities/qdriverstation
arch = i686
arch = x86_64
license = MIT
makedepends = git
depends = sdl2
depends = qt5-multimedia
+ depends = qt5-quickcontrols
provides = qdriverstation
conflicts = qdriverstation
- source = qdriverstation::git+https://github.com/WinT-3794/QDriverStation.git
+ source = qdriverstation::git+https://github.com/FRC-Utilities/QDriverStation.git
md5sums = SKIP
pkgname = qdriverstation-git
diff --git a/PKGBUILD b/PKGBUILD
index 7f2539784811..7cab5b5d41e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
pkgname=qdriverstation-git
-pkgver=r778.1601ab1
+pkgver=r1054.9393cc2
pkgrel=1
-pkgdesc="Drive your FRC robot with your phone or tablet!"
+pkgdesc="Open source clone of the FRC Driver Station"
arch=('i686' 'x86_64')
-url="https://github.com/wint-3794/qdriverstation"
+url="https://github.com/FRC-Utilities/qdriverstation"
license=('MIT')
groups=()
-depends=('sdl2' 'qt5-multimedia')
+depends=('sdl2' 'qt5-multimedia' 'qt5-quickcontrols')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=()
-source=('qdriverstation::git+https://github.com/WinT-3794/QDriverStation.git')
+source=('qdriverstation::git+https://github.com/FRC-Utilities/QDriverStation.git')
noextract=()
md5sums=('SKIP')
@@ -41,4 +41,7 @@ check() {
package() {
cd "$srcdir/${pkgname%-git}"
make INSTALL_ROOT="$pkgdir/" install
+
+ # Install MIT license
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}