summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-08-29 18:20:33 +0200
committera8212023-08-29 18:20:33 +0200
commit05c990f454acc1b0d367a4f0adf272919040e464 (patch)
treef06b6eab4c912258e49c54882b9569e8620af2d5
parent31b016e6d6d8b0a08adf8ee50d007080d4cbb9b4 (diff)
downloadaur-05c990f454acc1b0d367a4f0adf272919040e464.tar.gz
Switch to LLVM15
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6beacaff1139..33f5f25f8b2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = postgresql-git
pkgdesc = Sophisticated object-relational DBMS (Git version)
- pkgver = 16.beta2.r311.g1a4fd77db8
- pkgrel = 2
+ pkgver = 16.beta2.r329.g63956bed7b
+ pkgrel = 1
url = https://www.postgresql.org/
arch = x86_64
license = custom:PostgreSQL
@@ -16,8 +16,8 @@ pkgbase = postgresql-git
makedepends = icu
makedepends = systemd
makedepends = libldap
- makedepends = llvm
- makedepends = clang
+ makedepends = llvm15
+ makedepends = clang15
makedepends = libxslt
makedepends = util-linux
makedepends = git
@@ -74,7 +74,7 @@ pkgname = postgresql-git
depends = icu
depends = systemd-libs
depends = libldap
- depends = llvm-libs
+ depends = llvm15-libs
depends = libxslt
depends = lz4
depends = zstd
diff --git a/PKGBUILD b/PKGBUILD
index 5a421e78d1b3..097d53fcc57d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgbase=postgresql-git
pkgname=('postgresql-libs-git' 'postgresql-docs-git' 'postgresql-git')
-pkgver=16.beta2.r311.g1a4fd77db8
-pkgrel=2
+pkgver=16.beta2.r329.g63956bed7b
+pkgrel=1
pkgdesc='Sophisticated object-relational DBMS (Git version)'
url='https://www.postgresql.org/'
arch=('x86_64')
license=('custom:PostgreSQL')
makedepends=('krb5' 'libxml2' 'python' 'perl' 'tcl' 'openssl'
- 'pam' 'zlib' 'icu' 'systemd' 'libldap' 'llvm' 'clang' 'libxslt'
+ 'pam' 'zlib' 'icu' 'systemd' 'libldap' 'llvm15' 'clang15' 'libxslt'
'util-linux' 'git' 'docbook-xml' 'docbook-xsl')
source=(git+https://git.postgresql.org/git/postgresql.git
postgresql-run-socket.patch
@@ -75,6 +75,7 @@ build() {
# Fix static libs
CFLAGS+=" -ffat-lto-objects"
+ LLVM_CONFIG=llvm-config-15 CLANG=/usr/lib/llvm15/bin/clang \
./configure "${configure_options[@]}"
make world
}
@@ -127,7 +128,7 @@ package_postgresql-libs-git() {
install -m 644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq"
install -m 644 pg_config_manual.h "${pkgdir}/usr/include"
- # these he aders are needed by the not-so-public headers of the interfaces
+ # these headers are needed by the not-so-public headers of the interfaces
install -m 644 c.h "${pkgdir}/usr/include/postgresql/internal"
install -m 644 port.h "${pkgdir}/usr/include/postgresql/internal"
install -m 644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal"
@@ -156,7 +157,7 @@ package_postgresql-git() {
pkgdesc='Sophisticated object-relational DBMS'
backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
depends=("postgresql-libs-git" 'krb5' 'libxml2' 'readline'
- 'openssl' 'pam' 'icu' 'systemd-libs' 'libldap' 'llvm-libs'
+ 'openssl' 'pam' 'icu' 'systemd-libs' 'libldap' 'llvm15-libs'
'libxslt' 'lz4' 'zstd')
optdepends=('python: for PL/Python 3 support'
'perl: for PL/Perl support'