summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-07-14 14:21:27 +0200
committerMartino Pilia2019-07-14 14:21:27 +0200
commit0608793d686a06c6b189ca62f817a91846e70df8 (patch)
tree7fb6ecab65842fadaaa79983fcd9eefa07133472
parent3373d4df490e304c235ebf9b747856a7bc94c19f (diff)
downloadaur-0608793d686a06c6b189ca62f817a91846e70df8.tar.gz
Version 0.9.10
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD60
2 files changed, 51 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1da7825da21d..26e89c9228e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = inviwo
pkgdesc = Software framework for rapid visualization prototyping
- pkgver = 0.9.9
- pkgrel = 2
+ pkgver = 0.9.10
+ pkgrel = 1
url = http://www.inviwo.org/
arch = x86_64
license = BSD
+ makedepends = git
makedepends = cmake
- depends = qt5-base>=5.3
+ depends = libtirpc
depends = python
- source = http://weber.itn.liu.se/~ricen76/inviwo/v0.9.9/inviwo-v0.9.9-src.tar.gz
+ depends = qt5-base
+ source = git+https://github.com/inviwo/inviwo.git#tag=v0.9.10
source = inviwo.desktop
source = inviwo.sh
source = icon_24.png::https://avatars1.githubusercontent.com/u/10848351?s=24
@@ -16,14 +18,14 @@ pkgbase = inviwo
source = icon_48.png::https://avatars1.githubusercontent.com/u/10848351?s=48
source = icon_72.png::https://avatars1.githubusercontent.com/u/10848351?s=72
source = icon_256.png::https://avatars1.githubusercontent.com/u/10848351?s=256
- sha512sums = 6b034d2e48ab4edeb966c5d5d570c281ea104273cbb68d78949e5819d8ca365e8a5bedef562c4f2871915c9bc6f4b5971a70a1dfa1208d73b66ac0cd5c506762
- sha512sums = 97681c94e09fbace0b470599bc7d5954fa89776d30b738dd48814ffb9ff3a1c428bd5f6fe5785e43a633fcaf48dfbb600e92ecf571c49c99a28dd76b9945a745
- sha512sums = 890caae628ff011dfe67a2b2aea9afc7c40f87f21cebb9c3ef43c1f7d9b93fd94ebd4dc943c67958198eef7c6ab3c476e887a4b5258563a6d0804b27c725ba70
- sha512sums = 6e5e357bc9f0f9d477f5325f850042ed98aee9adba0515a527d5ff94854e1318a236adea029e8aead429046ccb371dff658065c12c331deb002e80175b0bc510
- sha512sums = 01f7089949279e0fe5f3131484ad8c8854e053614ad7430c779c81ab13b10f3ffb28fd8e1ff5072d2aa036fc983e16c37b54daf583c4991c26dc8c392cb21c60
- sha512sums = ba1e53a6dc6e109e1b8fd54f32e2bfe2755c6697b8750c468947e4410ed843df90a2c541e1771fecbadc1f05969fb4bf094e7590709e8b3919e08cc796685ced
- sha512sums = 7a879df4bc4fa04d3048aa9c7f2c763eebcc1a224c5afc1e8f14512c8da09422e72655d82d597665455960defce7266d013b9fc35b36f88426c192c8dc4f7141
- sha512sums = d018ef5a502fcc2e21d40450d73094bb705d42c8dea0ebb1d27b7a0df43626f931700a0511b29ba31287ef6795b59569b4a79457553701aa47983ede8dbd39c9
+ sha256sums = SKIP
+ sha256sums = a39bce23e91e85d333c540c4b1461a3b80c4890d96fcd400657f9788aedc72a1
+ sha256sums = e3d9cb272f6ad90f530c7c3f557409fae4130b5f6221c10dc7321287005f8d3d
+ sha256sums = 6f8bd81ba66de5739fccca7ba24fd8b96bc1ca0d13dc69fb00f046a4676aeb33
+ sha256sums = abe1c9af7c61e1426a477a8ab45cdd9bde68cce0330c21df12c38f5ac41f5c80
+ sha256sums = 7490e3beffc315ad3c37f18879668659d572ff06069ec094d5212e467c533da4
+ sha256sums = 92469cc044cfef24013d04a2e0098052f82d2479eedfef75e83b2cdc8fdebd01
+ sha256sums = 625eb81ec86636c28f02d373d3622a87512fc3791b3b61168d69694893ff2868
pkgname = inviwo
diff --git a/PKGBUILD b/PKGBUILD
index 9636d0c0049c..ea771e39efdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,53 @@
# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=inviwo
-pkgver=0.9.9
-pkgrel=2
+pkgver=0.9.10
+pkgrel=1
pkgdesc="Software framework for rapid visualization prototyping"
arch=('x86_64')
url="http://www.inviwo.org/"
license=('BSD')
-depends=('qt5-base>=5.3' 'python')
-makedepends=('cmake')
+depends=(
+ 'libtirpc'
+ 'python'
+ 'qt5-base'
+)
+makedepends=('git' 'cmake')
_icon_url='https://avatars1.githubusercontent.com/u/10848351'
-source=("http://weber.itn.liu.se/~ricen76/inviwo/v${pkgver}/inviwo-v${pkgver}-src.tar.gz"
+source=(
+ "git+https://github.com/inviwo/inviwo.git#tag=v${pkgver}"
"inviwo.desktop"
"inviwo.sh"
"icon_24.png::${_icon_url}?s=24"
"icon_32.png::${_icon_url}?s=32"
"icon_48.png::${_icon_url}?s=48"
"icon_72.png::${_icon_url}?s=72"
- "icon_256.png::${_icon_url}?s=256")
-sha512sums=('6b034d2e48ab4edeb966c5d5d570c281ea104273cbb68d78949e5819d8ca365e8a5bedef562c4f2871915c9bc6f4b5971a70a1dfa1208d73b66ac0cd5c506762'
- '97681c94e09fbace0b470599bc7d5954fa89776d30b738dd48814ffb9ff3a1c428bd5f6fe5785e43a633fcaf48dfbb600e92ecf571c49c99a28dd76b9945a745'
- '890caae628ff011dfe67a2b2aea9afc7c40f87f21cebb9c3ef43c1f7d9b93fd94ebd4dc943c67958198eef7c6ab3c476e887a4b5258563a6d0804b27c725ba70'
- '6e5e357bc9f0f9d477f5325f850042ed98aee9adba0515a527d5ff94854e1318a236adea029e8aead429046ccb371dff658065c12c331deb002e80175b0bc510'
- '01f7089949279e0fe5f3131484ad8c8854e053614ad7430c779c81ab13b10f3ffb28fd8e1ff5072d2aa036fc983e16c37b54daf583c4991c26dc8c392cb21c60'
- 'ba1e53a6dc6e109e1b8fd54f32e2bfe2755c6697b8750c468947e4410ed843df90a2c541e1771fecbadc1f05969fb4bf094e7590709e8b3919e08cc796685ced'
- '7a879df4bc4fa04d3048aa9c7f2c763eebcc1a224c5afc1e8f14512c8da09422e72655d82d597665455960defce7266d013b9fc35b36f88426c192c8dc4f7141'
- 'd018ef5a502fcc2e21d40450d73094bb705d42c8dea0ebb1d27b7a0df43626f931700a0511b29ba31287ef6795b59569b4a79457553701aa47983ede8dbd39c9')
-
-_sources="var/lib/jenkins/workspace/Public/Inviwo-public/$pkgname"
+ "icon_256.png::${_icon_url}?s=256"
+)
+sha256sums=('SKIP'
+ 'a39bce23e91e85d333c540c4b1461a3b80c4890d96fcd400657f9788aedc72a1'
+ 'e3d9cb272f6ad90f530c7c3f557409fae4130b5f6221c10dc7321287005f8d3d'
+ '6f8bd81ba66de5739fccca7ba24fd8b96bc1ca0d13dc69fb00f046a4676aeb33'
+ 'abe1c9af7c61e1426a477a8ab45cdd9bde68cce0330c21df12c38f5ac41f5c80'
+ '7490e3beffc315ad3c37f18879668659d572ff06069ec094d5212e467c533da4'
+ '92469cc044cfef24013d04a2e0098052f82d2479eedfef75e83b2cdc8fdebd01'
+ '625eb81ec86636c28f02d373d3622a87512fc3791b3b61168d69694893ff2868')
prepare() {
- cd "$srcdir/$_sources"
-
- # do not try to use the source folder as base path for the executable
+ cd "$srcdir/$pkgname"
+
+ git submodule sync --recursive
+ git submodule update --init --recursive
+
+ # do not try to use the source folder as base path for the executable
sed -i 's,IVW_TRUNK,std::string("/opt/inviwo"),' src/core/util/filesystem.cpp
+ # fix missing libraries in sigar
+ sed -i '27i#include <sys/sysmacros.h>' ext/sigar/src/os/linux/linux_sigar.c
+ sed -i \
+ -e '69itarget_link_libraries(sigar PRIVATE libtirpc.so)' \
+ -e '69itarget_include_directories(sigar PRIVATE /usr/include/tirpc)' \
+ ext/sigar/CMakeLists.txt
+
mkdir build || :
cd build
@@ -41,22 +55,22 @@ prepare() {
}
build() {
- cd "$srcdir/$_sources/build"
+ cd "$srcdir/$pkgname/build"
make
}
package() {
- cd "$srcdir/$_sources/build"
+ cd "$srcdir/$pkgname/build"
_install="$pkgdir/opt/inviwo"
mkdir -p "$_install" "$pkgdir/usr/bin"
cp -r bin "$_install/bin"
cp -r lib "$_install/lib"
- install -Dm755 $srcdir/inviwo.sh "$_install/bin/."
+ install -Dm755 "$srcdir/inviwo.sh" "$_install/bin/."
ln -s /opt/inviwo/bin/inviwo.sh "$pkgdir/usr/bin/inviwo"
- cd "$srcdir/$_sources"
+ cd "$srcdir/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"